9

Today I installed Windows 10, version 1607, on my MacBook Pro (Retina 15in Late 2013). Before this I had Bootcamp setup with Win7. So, I started out by deleting the old Win7 Bootcamp Partition using the Bootcamp Assistant on Mac and then created a new partition and went on to install Windows 10. Everything seems to have gone smoothly: Partitioning, Installation of Windows 10, and the Apple Bootcamp drivers.

However, the Mac Partition does not show up in Windows File Explorer.

I found this related thread Why I can not see mac partition under windows installed with bootcamp?

I have run the commands with the following results:

DiskUtility Info

It looks like my MBP is not using CoreStorage. FileVault is deactivated. ... and on my prior Windows 7 Bootcamp partition (that I deleted before setting up a new one for Windows 10) the Mac Partition was showing up correctly.

Here's a pictures of Windows 10 Disk Management:

Windows 10 Disk Management overview

Does anyone know what's going on here?

  • Windows does not natively have the ability to mount or read an HFS+ volume. If you could see it in Windows 7 then you had a third-party driver making it possible. I know Apple at one time included an Apple HFS Read Only Driver as a part of the Boot Camp software. I do not know if it's still available with the Apple Boot Camp Drivers for Windows 10 because I no longer have a need for Windows. There are other third-party HFS+ Drivers for Windows. MacDrive is one, and Paragon HFS+ for Windows. – user3439894 Sep 6 '16 at 2:31
  • 1
    It must have been included in the Bootcamp drivers by Apple. I never installed any other 3rd party HFS+ drivers when using Windows 7. I cannot imagine that or why Apple have changed including this functionality in the current drivers for Windows 10. How can I find out? I think other users of Bootcamp Windows 10 are able to see/read their Mac partition from Bootcamp Windows 10. – Phil Sep 6 '16 at 2:38
  • As I already said, "I do not know if it's still available with the Apple Boot Camp Drivers for Windows 10 because I no longer have a need for Windows." That said, four years ago when I last had a Boot Camp Windows install the two drivers installed by Apple's Boot Camp Windows Software were AppleHFS.sys and AppleMNT.sys and were located in C:\Windows\System32\drivers\. What it may be for Windows 10 I just can't say. – user3439894 Sep 6 '16 at 3:00
  • It's still the same: both these files (AppleHFS.sys & AppleMNT.sys) are in C:\\Windows\System32\drivers under Windows 10.. The thread that I linked in my description of the problem suggests that if the Mac Partition is HFS+ (and FileVault ist deactivated) BootCamp drivers would usually allow to read the Mac partition in Windows 10. Thanks anyway. – Phil Sep 6 '16 at 3:30
  • What does Windows 10 Disk Management show? Can you include a snapshot of what is shown? – David Anderson Sep 6 '16 at 3:31
10

Apple HFS+ drivers DO work after 1607 Anniversary Update, they just have problems mounting the drives. You can mount them manually with the risks associated with it. (Personally, I have encountered exactly zero bugs/problems in several weeks of hard usage and testing on 3 computers, so I started recommending my method on the net. I am writing this warning anyway, as mounting a partition forcibly may still have unforeseen consequences I have yet to face.)

Firstly, make sure you have drivers from 6.0 installed, 6.1 does not have HFS+ drivers. You can reinstall to be sure, or

  1. Go to Windows\system32\drivers\ check if AppleHFS.sys and AppleMNT.sys is there.

  2. Run regedit, go check if "AppleHFS" and "AppleMNT" keys exist in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\"; each should also have some string and dword values in it.

Personally, I would extract these two .sys files from a 6.0 install, Google on how to install them via registry tweaks, and make the habit of always using the most up-to-date bootcamp drivers. Apart from bug fixing and optimisations, new Macs a few years into future will just not function properly on 6.0 drivers.

Reboot after installing your Apple HFS drivers. Nothing will show up on 1607 after reboot, but I would still feel better to install these drivers before we try and mount them.

Secondly, make sure you are not using CoreStorage. I am reasonably certain "read only" HFS driver can't do any harm, but it's better to be safe than sorry.

If you are good to go, you have two options:

Option #1: mount your bootcamp partition via DOS Devices registry edit:

  1. Run regedit, navigate to "HKEY_LOCAL_MACHINE/system/CurrentControlSet/Control/Session Manager/DOS Devices/"

  2. Right click > new > add string

  3. Enter your drive letter by adding ":" In "data" type "\Device\HarddiskVolume#", where # will be the volume number of your partition as it would be detected in MS-DOS. In your case, it SHOULD be 2, as it is the 2nd partition of disk0. (In MY computer, disk0 has 1 partition, my macOS partition is 2nd one on disk1, so MY partition number is 3, just count your partitions starting with 1.)

    Your registry entry should (provided nothing is changed in 4 months you posted this) show "D:", "REG_SZ" and "\Device\HarddiskVolume2" for name, type and data respectively (assuming D: is the drive letter you want for your macOS partition).

  4. Never use letter C: or any other drive letter that may contradict with your Windows installation, as this may render your Windows unbootable. (Or may not, it's just a matter of luck whether Windows chooses to mount DOS devices first, or it's own disk management.) It is (probably) safe to do trial and error on volume #, it won't break anything even if you accidentally select your Windows partition, it will just mount it twice with different letters.

  5. Reboot and your macOS partition should be there.

  6. Before using, go to properties of your new disk in "This PC" and your "file system" should be HFS and it should report used and free spaces correctly. If it is RAW, never try to reformat, check your AppleHFS.sys install.

Option #2: use a program that can mount disks via Session Manager (in other words, it will make the registry entries for you).

  1. Download ext2fsd even though you probably have nothing to do with ext2 or linux.

  2. Open Ext2 Volume Manager. In "File System" tab, your macOS partition will show as "HFS". If you installed ext2fsd before successfully installing bootcamp drivers, it will just show as "RAW". (kind of proving bootcamp drivers DO work)

  3. Right click, select assign drive letter (or change drive letter).

  4. In the pop-up menu, select the drive letter first, then select the tick "Create a permanent MountPoint via Session Manager." It -weirdly- closes the pop-up before you click "OK". (Ext2fsd is a little buggy, you should select drive letter first, then select the tickbox. If you want to change drive letter, I suggest removing the existing one first, then re-add it from scratch)

  5. Reboot, and the macOS partition will be there just like before anniversary update.

In both options, your diskpart or disk management will still show your HFS partition as RAW, (so does minitool partition wizard etc), but it will function normally, and you should be able to confirm it as HFS in properties menu. In analogy, this method tries to define your partition letter like defining a legacy COM or Printer (LPT) port.

8

Apple officially supports Windows 10 on the newer Macs. Generally these are the 2012 and later models. The originally released version of Windows 10 was number 1511. The Windows version can be determined by opening a Command Prompt window and entering the command winver. Below is example.

enter image description here

For version 1511, read only access to HFS+ formatted partitions can be enabled by installing the Boot Camp Support Software.

Recently, Microsoft has released a new version numbered 1607. This is referred to as the Windows 10 Anniversary Update. This version has a bug that can prevent read only access to HFS formatted volumes. Therefore, if you are using version 1607 of Windows 10, you may not be able to access HFS formatted volumes even if you have installed the Boot Camp Support Software. Until this bug is fixed, users will have to use version 1511 or find another way to copy data from HFS formatted volumes.

  • 1
    Just for an update. I'm running macOS Sierra (Beta) on a Mid 2011 iMac and my Bootcamp partition is running Windows 10 Insider Preview Version 1611. Before upgrading to Sierra, I was able to see my Macintosh HD from the Windows partition, in fact, my Winamp was still pointing to my iTunes library on the Mac partition which was "G:/". Between the update to Sierra and all the Windows 10 updates that happened in the interim, I'm still trying to solve this one myself. Should I have any luck, I'll post my answer here. – ben.kaminski Oct 10 '16 at 18:02
  • Any updates here to post? Thanks – Gmeister4 Nov 26 '16 at 13:18
  • this explains the cause (of my problems), answer by Andraxxus has the fix. – Leon Feb 15 '17 at 11:48
  • @Gmeister4 discussions.apple.com/thread/7629103?start=0&tstart=0 just a bit more details but seams to be still an issue – Kuncevic Jul 25 '17 at 11:49
1

You can use HFS+ for Windows® 11 by paragon software. Worked for me.

https://www.paragon-software.com/home/hfs-windows/download.html

  • I just tried installing this with Windows 10 on my Bootcamp partition, and got the message " :( Unfortunately, no supported volumes have been found." My partition running High Sierra can't be seen at all from Windows. – Uniphonic Jun 26 '18 at 17:34
0

Followup on Andraxxus's answer.

1. Option 1 did not work for me. Run command line "diskpart", "list volume", shows that the mac hfs+ partition was not mounted. While "select disk 0", then "list partition" will find presence of the partition.

2. Option 2 ext2fsd will run, but after rebooting windows 10, windows will run scanning and repairing drive C. Then, the drive D: is gone again.
Solution : Go to regedit, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager, Change the BootExecute string to "autocheck autochk /k:C *"

You must log in to answer this question.

protected by Community May 7 at 3:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .