My mid-2010 MBP is malfunctioning. For all the keys I have to press down quite hard to get a response. "slow keys" is off. I spilled some water around the keyboard a few days ago, that's about when this started. I started popping keys off and it was rather dirty under each key, I cleaned them with a cotton swap and rubbing alcohol. Has made an improvement, more responsive but still hard to press. Is there another method for cleaning them better. Or something else that could cause low responsiveness?


2 Answers 2


The link provided in the comment has good advice, but not everyone can take their Apple gear to a professional — this is especially true if you live in a country that does not have an Apple Store or do not live in a larger city.

So, if you can't get your laptop to a professional, then you'll have to take care of the keyboard yourself until you can.

  • Double-check your keyboard settings in the System Preferences, you mention "slow keys" but there are two settings in there: "key repeat" and "delay until repeat" which affect the timing of keystrokes to response.

  • Hook up an external keyboard (any USB keyboard will work, though you may loose some Apple-specific functionality if using an non-Apple keyboard). Pressing extra hard could cause more damage and further exacerbate the situation you already have.

  • Get a repair guide from a site like ifixit.com which will show you how easy or difficult (it's usually on the difficult side) it is to remove and replace the keyboard or at least get to it for a closer look to find a hardware cause. This will help you to clean, dehydrate, and reassemble you laptop as the linked comment suggests.

Depending on what was in the water and how much of it was spilled and how long before cleaning under the keys took place, you may have a corrosion problem where the residue left behind after the liquid evaporated is gunking things up.


From your settings go to accessibility Scroll down to keyboard Click on keyboard , it will be highlighted in blue and a pop up will appear on the right, uncheck enable slow Keys.Hope it helps!

  • OP already said slow keys is off.
    – Tetsujin
    Nov 5, 2017 at 7:35

Not the answer you're looking for? Browse other questions tagged .