0

When I open System Preferences, go to Privacy, unlock the pane with my password. When I click on the 'Turn on Location Services' checkbox, the computer freezes, and the box turn blue and immediately turns white. How do I fix this?

  • I had a similar issue. The problem has been solved after fix permissions on /var/db/locationd folder. What is permissions on your locationd folder? You can check it with the command line below : sudo ls -lsa /var/db/ | grep locationd – hexley Jun 26 '17 at 7:37
1

What you are describing sounds similar, but not identical, to the problems discussed in this Reddit thread. No solution to the problem was presented there besides one suggestion of a possible script to enable it.

To give you a better answer, though, it would be helpful to know more about your setup. What type of Mac do you have (how much RAM too), does the WiFi work like normal, which version of OS X are you running, how long have you experienced the issue, did anything lead up to it, and are there any other details that might be unusual and relevant.

You might be able to get more professional assistance by sending a direct message to Apple Support's Twitter account. There may be specific diagnostics to try.

Some other ideas to try would be to repair disk permissions (depending on which version of OS X you're on) or verify disk in Disk Utility. Or log in to a guest or other new user account to see if it is specific to your account or not. Or you can try resetting the P-RAM. Or in the end of the day you may just need to make a backup, reinstall OS X, and restore.

  • I have 16gb 1600mhz ram. I am running macOS Sierra, but the same did not work on EI Captain. – NullCoderExists Sep 4 '16 at 10:28
  • @SuryanIsaac Please edit your original question with those details as well as the other details I asked for and the results of any the suggestions I brought up that you tried. – kal-al Sep 4 '16 at 17:52
1

Try clearing temporary/cache files

These files are automatically generated and don't contain any of your data. Sometimes, they will corrupt and create problems similar to yours.

Please backup all data and read the entire answer before proceeding.

First, copy the below path and paste it into the Go to Path dialog box found by going into the Go menu in Finder, or right-click it and select Services ▹ Reveal in Finder. It might be simply Services ▹ Reveal.

/var/folders/zz/zyxvpxvq6csfxvn_n00000sm00006d

A folder should open with another folder in it selected. The selected folder would be zyxvpxvq6csfxvn_n00000sm00006d. Select only that folder and move it to the Trash. Do not tamper with the rest of the folder.

You may be prompted for your administrator login. After you empty the Trash, restart your computer. Turning on Location Services should now work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .