0

We are using Mavericks OS X server with the Time Machine service. We had originally setup our Time Machine server to limit remote backups (backups of desktops and laptops) to 1,000 GB of space.

However, some machines need 2,000 GB of backup space, so we increased the Time Machine backup destination to 2,000 GB. But, when workstations backup to the OS X server, they complain about not having enough space and the backup size is just a few GB shy of 1,000 (e.g. 992 GB).

We restarted the server and the client, but the problem persists.

On the client, the backup destination was removed, Time Machine turned off, the destination was added back and Time Machine turned back on but still the problem persists.

Why am I not able to get more than 1,000 GB of backup space even though I've configured the Time Machine server to limit to 2,000 GB?

  • Have you tried turning off Time Machine and/or unselecting the Server desitation on the client machine, and then reselecting the Server as a destination? That might cause the client to re-learn what the quota is. – j-beda Sep 3 '16 at 14:50
  • @j-beda thanks for the suggestion. We rebooted, but that didn't work. I will try to re-select the destination. But, I'm concerned that will restart my backup from scratch, wiping out my history. – Swisher Sweet Sep 9 '16 at 11:49
  • it has been my experience that reselecting a server destination inherits existing backups rather than replacing them. – j-beda Sep 10 '16 at 16:37
  • @j-beda I have re-selected the destination but it still thinks it is limited to 1,000 GB. – Swisher Sweet Sep 14 '16 at 17:41
  • Drat. I assume that TM has been turned off and them back on for BOTH the client and the server? – j-beda Sep 15 '16 at 19:57
0

Here's what you need to do to resize an existing Time Machine sparsebundle without loosing data on a Time Machine server (OS X Server):

  1. Turn off Time Machine Server.
  2. Turn off Time Machine Client(s).
  3. Resize the disk image and the partition following these instructions. Execute these steps on the server, where the drive is attached if possible.
  4. After 3 completes, turn on Time Machine Server.
  5. Remove backup destination on client and add it back.
  6. Turn on client Time Machine and perform a backup.

I followed these steps and I was able to increase my backup destination from 1TB to 2TB without loosing backup history.

Here are a few issues I ran into and how I worked around them:

  1. The Resize Image icon was greyed out in Disk Utility. This was because my logged in user didn't have read/write access to the sparse bundle. Rather than change those permissions, I logged in as that user and could resize image.

  2. Nothing appeared to happened after I told Disk Utility to resize the image. This is apparently a defect in Disk Utility. While there are no indicators resizing the image worked, if you go to the partitions tab, you will see the image was increased.

  3. It took 4 days to complete. Increasing the partition size appeared to have kicked off a disk check of sorts. That process and checking multi-linked directories took about 4 days to complete. This was on a directly attached 7,200 RPM drive array attached via USB 3 with about 1TB of backup history. I don't know of any way to speed this process up, so just be aware it may take a very long time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .