2

I'm having problems with my main system OSX volume.

When running sudo diskutil verifyVolume / :

$  sudo  diskutil verifyVolume  /
Password:
Started file system verification on disk1 OSX
Verifying storage system
Checking volume
disk0s2: Scan for Volume Headers
disk0s2: Scan for Disk Labels
Logical Volume Group 986FADEF-FEF3-428E-944A-82EBB8F38184 on 1 device
disk0s2: Scan for Metadata Volume
Logical Volume Group has a 24 MB Metadata Volume with double redundancy
Start scanning metadata for a valid checkpoint
Load and verify Segment Headers
Load and verify Checkpoint Payload
Load and verify Transaction Segment
Load and verify Transaction Segment
Incorporate 1 newer non-checkpoint transaction
Load and verify Virtual Address Table
Load and verify Segment Usage Table
Load and verify Metadata Superblock
Load and verify Logical Volumes B-Trees
Logical Volume Group contains 1 Logical Volume
Load and verify 126F7B49-5C33-457F-B6AB-3A6CD220F151
Load and verify D073860B-299F-4146-B68B-7233BD5488CB
Load and verify Freespace Summary
Load and verify Block Accounting
Load and verify Live Virtual Addresses
Newest transaction commit checkpoint is valid
Load and verify Segment Cleaning
The volume 986FADEF-FEF3-428E-944A-82EBB8F38184 appears to be OK
Storage system check exit code is 0
Verifying file system
Using live mode
Performing live verification
Checking extents overflow file
Incorrect number of file hard links
Checking catalog hierarchy
Checking volume bitmap
(It should be 22232741 instead of 21777947)
File system check exit code is 8
Error: -69845: File system verify or repair failed
Underlying error: 8: POSIX reports: Exec format error

The error:

Checking volume bitmap
(It should be 22232741 instead of 21777947)
File system check exit code is 8
Error: -69845: File system verify or repair failed
Underlying error: 8: POSIX reports: Exec format error

Also tried:

    $  sudo  diskutil repairVolume  /
Error starting file system repair for disk1 OSX: Unable to unmount volume for repair (-69673)

So I tried it in recovery mode (Cmd+R on boot), but I have troubles getting past the encryption (diskutil coreStorage unlockVolume) giving me a generic error that it cannot unlock the volume.
Here my noobish OS-X volume management "skills" end.

The system works, overall, but I cannot resize the volume, for example and all volume checks end in mysterious errors, like the first one above, for example, which is unnerving.

Need help. TIA.

MacBook Pro (Retina, 13-inch, Late 2013), OS X 10.11.3

1

You can use the Disk Utility application from the recovery partition to do all of this (unlock and mount the disk, run repair, etc.). If you have any other disk repair utilities maybe give them a shot? Either way, if you don't have a backup already I'd make a copy ASAP.

Another idea is to boot into single user mode (Command-S on boot) and run fsck but not sure it'll be any different.

0

My solution involved:

  • turning off FileVault (I think this was the critical unblocking/enabling factor to move forward with the other tools)
  • running fsck -fy in single-user-mode MULTIPLE TIMES until the errors disappeared
  • resizing the partition to full disk, by adding another partition in the unused space and then deleting it, grabbing the rest of the space (might not be necessary for you). This involved downsizing the system partition (by accident), but I felt like this might have been a turning point. Note: the resizing took a long time, ~1h, without a good progress indicator or ETA shown.
  • running diskutil verifyVolume/repairVolume MULTIPLE TIMES until the errors disappeared (might not be necessary)

Given the initial re-occurrence of the errors after e.g. fsck (all fixed in the end!), I thought that perhaps this was a hardware problem (e.g. SSD wearing out or something), but I've checked SMART status and it all seems okay. Will keep my eyes open, though.

An important factor was repeating the steps until the errors stop showing and new errors stop appearing. Don't give up. Persistence and "shaking it in various ways" until the cruft is shaken out :). Weird, but worked.

After the errors stopped, I have re-enabled FileVault and the errors did NOT reappear! Yeah.

Also checked with Onyx which previously showed error. Result: no problems found, yeah.

A less mysterious solution could have probably been to reinstall the system from scratch and perhaps restore from backup, but I felt like this would be too much hassle (although might have taken less time really).

  • Ha! Nice- glad it's working again... – MacManager Sep 2 '16 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .