23

This question already has an answer here:

Just now using MacOs Sierra's Mail client. Compared to what happened on El Cap, which worked fine. It seems that now Gmail is accumulating drafts, in other words, once the email is sent, there may be one or many drafts of the email in the drafts folder. Probably corresponding to how many autosaves happened.

Can I stop this from happening?

marked as duplicate by Allan, grg, IconDaemon, bmike Feb 21 '17 at 14:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'm using El Capitan, and I'm having the same behavior. Seems that's a gmail problem then. – lpuerto Sep 13 '16 at 10:25
28

I had just fixed this problem in El Cap when I updated to Sierra, and it came back in full force. The solution is simple though. In this version of the Mail app there's no more checkbox for saving drafts on the server, but you can manually select where Mail stores your drafts for you.

As before, go to Settings > Mailbox settings and in the Drafts drop-down menu select either [Gmail]/Drafts or [On my mac]/Drafts.

Selecting the latter option will prevent Mail from sending your drafts to the Gmail server, resolving the problem with leftover drafts.

Obviously, this does mean that you can't work on your Mail drafts in the Gmail web version.

  • 1
    your answer does not make any sense. There is no such thing as concepts anywhere. – user1256923 Feb 28 '17 at 10:49
  • But changing the draft's email body, for example, creates duplicate local drafts too. – Iulian Onofrei Sep 26 '17 at 8:43
6

I don't know if it's just a Sierra issue, but I experienced the exact same thing when I upgraded to El Capitan. That's what happens when you check "Store draft messages on the server" in Mail > Preferences > Accounts > Mailbox Behaviour.

I fixed the issue in the following way: Uncheck the checkbox for the drafts. You won't be able to see the same draft email on multiple devices, but you'll avoid this annoying behaviour. You can also set, at the Gmail web interface, the Gmail "Drafts" folder not to show in IMAP so that you won't have an extra, unneeded Drafts folder.

  • 2
    in Sierra there is nothing to uncheck. Your answer does not make any sense. – user1256923 Feb 28 '17 at 10:52
1

This happens on gmail and on exchange/office 365 for me. It happens on and iOS for me too I addition to macOS so I just delete them later. I can't tell if it's intentionally designed on the gmail / exchange side or an optimization when you connect to a load balancer and don't have one actual server to send mail.

Apple's iCloud seems to handle this better and you could always run an on-premesis outbound mail server if you cannot allow drafts to accumulate or just clean them up periodically or disable saving drafts to the server.

My long term solution was to move my personal mail to iCloud and my business mail to FastMail. No more google and their take on IMAP has made my life with native mail clients much better.

  • Are you on Sierra? – pitosalas Aug 31 '16 at 16:49
  • @pitosalas I have about 5 machines testing that now. – bmike Aug 31 '16 at 16:51
  • have you solved it? we'd like an answer that works, as opposed to an answer that does not, and all the answers I find do not -- in this or the supposedly duplicated question (which also does not fix the problem) – user1256923 Feb 28 '17 at 10:54
  • @user1256923 Yes. The solution for me was to ditch gmail. Also, try disabling draft saving to the server, but that seemed a worse trade off for me. – bmike Feb 28 '17 at 12:02

Not the answer you're looking for? Browse other questions tagged .