I have a WD external usb3 hard disk. I'm having a similar problem as mentioned in number of posts, which also offer solutions I've exhaustively tried. But of course some poster will ask me to list them all. I"ve closed many, googled for ages, here's some tabs that were still open when I finally posted.

How to make my iMac recognize my USB external hard drive?

How to Erase External USB Drive Which Won't Mount & Isn't Recognized

How do I recover a HFS+ journaled drive?

USB Drive Will Not Mount, Not Listed in Disk Utilities, but Found In System Profiler

In my case, I plugged the HFS+ formatted drive into my Windows 7 box and installed HFSExplorer and the drive mounted right away on Windows and I was able to copy files from it. The drive isn't damaged.

Here's some other things I've tried:

  • rebooting
  • using system information to see the usb devices (the drive is NOT listed)
  • swapping between 3 different known working USB cables
  • trying the usb port on the left of my MBP and the usb port on the right of my MBP
  • trying connecting USB hubs to the USB ports, verifying that these show in system information, THEN connecting the drive to those hubs
  • Connecting the drive to another Mac (yep, works just fine. Read/Write. Disk Utility verify doesn't report any problems).
  • Connecting drives other than this one to the MBP and confirming they work on both ports, behind hubs, and so on

this mac will not see this particular drive.

any ideas?

  • While the disk is plugged in, try running "diskutil list" to see if it's a mounting issue or possibly a hardware issue.
    – bret7600
    Commented Aug 31, 2016 at 11:26
  • If you boot to OS X Recovery, is the USB Disk visible in Disk Utility there? Commented Aug 31, 2016 at 12:53
  • Do you get any messages in Console.app when you try to plug it in?
    – root
    Commented Sep 1, 2016 at 13:13
  • What is the output of ioreg -p IOUSB -l -w 0? (terminal)
    – aeroxy
    Commented Aug 1, 2017 at 5:38
  • @aeroxy output of ioreg is pastebin.com/HYcWxMsZ; device that won't mount is the last one mentioned - Flash Drive FIT; here it is in disk utility imgur.com/a/xyjer
    – frumbert
    Commented Aug 9, 2017 at 11:00


You must log in to answer this question.

Browse other questions tagged .