1

I went to Settings and "New mail notifications on" is selected (there was a text as a link above it, I clicked on it).

However, it doesn't work, i.e., I don't receive any notification on a new mail...Any idea(s)?

  • I removed MacBook and added OS X as tags. Do you use google chrome and expect it to perform desktop notifications? – bmike Aug 30 '16 at 2:18
  • @bmike correct. I want to be notified when a new mail arrives, without having the tab of gmail open! There is a plugin for it, but I hope I could bypass it.... – gsamaras Aug 30 '16 at 2:20
  • chrome://settings/search#notifications <- Copy and paste that into your address bar in a new tab. Click on the highlighted Content Settings button and scroll down to Notifications. Ensure that either "Allow all..." or "Ask..." is enabled, and click Manage Exceptions to ensure that there isn't a line with "gmail" or "mail.google.com" in the URL that's set to Block. – tubedogg Aug 30 '16 at 2:34
  • @tubedogg "Ask..." is set and mail.google.com:443 is set to Allow. – gsamaras Aug 30 '16 at 2:40
  • Go to Gmail and turn notifications off completely. (While you're there, does it say in that block whether notifications are disabled in the browser? I have them disabled through Chrome and it tells me that in Gmail settings.) Close the Gmail tab. Go back to settings and remove the mail.google.com setting. Navigate back to Gmail, re-enable notifications in settings, and theoretically it should prompt you to decide if you want notifications enabled. Enable them and test again. – tubedogg Aug 30 '16 at 2:47

You must log in to answer this question.

Browse other questions tagged .