I just bought an HP m201dw printer, and while I can print wirelessly from my desktop wired to the router, I can't use AirPrint even though it is advertised as supporting it.

When I try to print a document from my iPad, I get an error message saying, "No Printers Found."


  • HP m201dw printer, initially configured to a Windows 10 PC through USB to select wifi network, but now running wirelessly only on the main network on a dhcp-given ipv4. All default protocols enabled, including AirPrint, Bonjour and IPP. Tried enabled IPPS, disabling ipv6, switching ePrint (web services) on and off, but none of those made the printer show up in AirPrint.
  • Windows 10 PC connected to router on ethernet. Prints to the wireless printer just fine. No issues accessing printer config wirelessly using either HP toolbox or web browser on DCHP-given IP. Also, the Bonjour Browser utility can see printer services (screeenshot below).
  • iPad Air running iOS 9.3.4. Cannot see printer when connected on the main wifi network. However, I can see and print using AirPrint when connected to the printer's own wifi network when "Wireless direct" is enabled on the printer, however that's not very useful - AirPrint is supposed to be available from the main wifi network on which all devices are connected.
  • ASUS RT-N16 router running TomatoUSB firmware v1.28.9054. All relevant devices (PC, iPad, printer) are visible in the list of connected devices, along with their IP addresses.

I don't really understand how AirPrint works and what it wants. Any insights on how I can start using AirPrint from my iPad?

Bonjour Browser

  • 1
    In the list of footnotes HP gives about AirPrint on their page for your printer, one caught my eye: "AirPrint only works on 2.4GHz networks." Try switching your router from 5Ghz or mixed mode to pure 2.4Ghz if you can.
    – owlswipe
    Sep 7, 2016 at 3:02
  • @JohnRamos My router only supports 2.4Ghz. Good thing to know, however. Thanks.
    – mtone
    Sep 7, 2016 at 15:02
  • Do other Bonjour services work on your network?
    – samh
    Sep 10, 2016 at 1:14
  • @samh Good question, the only service I can think of is the discovery of my AirVideoHD server (from iPad to PC), which I believe works through Bonjour. Any other suggestion for testing this?
    – mtone
    Sep 11, 2016 at 3:10
  • 1
    Check to make sure multicast traffic is permitted (i.e. Not filtered or blocked) on the router. However, others have had difficulty using AirPrint with that router, eg vip.asus.com/forum/…
    – samh
    Sep 11, 2016 at 11:34

3 Answers 3


The Windows PC isn't likely using AirPrint, at least not by default, so it's probably using another protocol such as IPP. Looking around I see there's a Bonjour Print Services for Windows utility from Apple. If you install that are you able to use Bonjour to print?

Have you checked for any firmware updates on the printer? Can you browse to the printer's web configuration page to confirm that AirPrint is enabled? Perhaps disable it, restart the printer, re-enable and then restart again?

  • I agree that the PC is not printing through AirPrint, also I confirm I have the latest firmware (20160418). I tried the utility -- it "sees" the printer but says it needs a driver. When clicking "Have disk" and pointing it to the .inf file of the "Basic Driver (no installer)" I downloaded on support.hp.com/us-en/drivers/selfservice/…, it says the software doesn't match the printer and crashes.
    – mtone
    Sep 11, 2016 at 2:55
  • Google says the Bonjour print services v2.02 page is dated from 2010, that might explains the crash on Windows 10.
    – mtone
    Sep 11, 2016 at 3:12
  • That's strange.. AirPrint doesn't require any drivers. From support.apple.com/en-us/HT201311 "AirPrint is an Apple technology that helps you create full-quality printed output without the need to download or install drivers."
    – MacManager
    Sep 11, 2016 at 20:15
  • Do you have any other devices on that wifi network that see the printer? It sounds like only the PC can see the printer on the network but it's connected via ethernet. Can you pull the ethernet from the PC and connect with wifi to verify that you still see the printer broadcasting via bonjour?
    – MacManager
    Sep 11, 2016 at 20:23
  • Your comment prompted to plug a wireless adapter on my PC and indeed, could not see the printer anymore using Bonjour Browser, helping narrowing down the problem. And I finally found a solution - thanks.
    – mtone
    Sep 12, 2016 at 0:19

Ok, I finally got this working. In short, the router was not forwarding multicast between wireless devices.


Several discussions mention a "Wireless Multicast Forwarding" option in the Advanced...Wireless Tomato router configuration page, however it appears it was removed in this particular TomatoUSB version. However, the option exists even if it's not available from the GUI.

This Tomato nvram default configuration file has the following line:

{ "wl_wmf_bss_enable",      "0"         },  // Wireless Multicast Forwarding Enable/Disable

This link gave me a pointer on how to work with these settings using the nvram command, and this thread also discusses this further.

Using telnet to the router, this command returned 0: nvram get wl_wmf_bss_enable.

Enable wireless multicast forwarding on TomatoUSB

  1. Telnet into the router or use the Tools...System page on the router administration page.

  2. Enter the command nvram set wl_wmf_bss_enable="1"

  3. Enter the command nvram commit

  4. Restart the router

While testing this, I kept the mDNS Tools running from my PC and finally started to see the periodic "Port open" messages coming from the printer's IP. I was able to print from my iPad as well.


This Should Work

Apple Toolbox

You can try to:

  • Confirm Your Printer has AirPrint
  • Make sure that the AirPrint-enabled printer is connected to the same Wi-Fi network as the iOS device. Note that Wi-Fi printers may take several minutes to join a Wi-Fi network. AirPrint cannot be used on cellular networks
  • AirPrint cannot be used on cellular networks Make sure Airplane mode is OFF Check that your printer has not turned off wireless If it is turned OFF, press the wireless button on the printer to get it running again. Turn your iOS device off and back on again. Turn your printer off and back on again. Turn off BOTH your router AND your modem, wait 30 seconds, and turn back ON Turn off Bluetooth and try printing. Make sure that your iPad / iPod / iPhone is running the latest version of iOS and your printer has the latest firmware version installed. Make sure that AirPrint is enabled in your printer settings. Check your printer’s manual for this. Change the Internet Printing Protocols (IPP) setting from Off to On to make the printer findable via AirPrint. The IPP (Internet Printing Protocol) is usually found under the printer’s Advanced Settings sub menu

(read all the solutions on apple toolbox)

  • Thanks, I'm not seeing anything on that page I haven't tried. However, several comments point to a potential problem since iOS 9.3. There might be an explanation there...
    – mtone
    Sep 11, 2016 at 3:17
  • Following that lead, the reddit thread reddit.com/r/ios9/comments/3q7lqj/ios_91_fails_to_airprint points to possible issues with ios9 and ipv6, I have disabled ipv6 on the printer and I don't believe my router/TomatoUSB supports ipv6.
    – mtone
    Sep 11, 2016 at 3:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .