2

MBP Early 2015 keep losing internet connection! Still connected to the router but no data in or out, can't even access router settings.

If I toggle wifi on and off it will be good for 20/30 minutes and then same cycle. What should I do, what is the problem?

I know the same exact question is out there but nothing is working!

I have tried:

  • Remove airport/network configs
  • sudo ifconfig awdl0 down
  • 5gHz band
  • Removed network
  • Replaced modem
  • Cleared DNS cache
  • Removed proxies in network settings
  • Disabled "wake for wi-fi network access

Don't know what else to do... Haven't done any PRAM or SMC resets.

  • Does this happen on all networks you connect to or just one? – samh Aug 28 '16 at 23:30
  • @samh I don't know at the moment. I will test this in couple hours on a public network. – Abdul Sadik Yalcin Aug 29 '16 at 13:33
  • @samh Happens on all networks. I just tried my bootcamp and no issues at all and way faster speed than I get on osx! – Abdul Sadik Yalcin Sep 28 '16 at 20:11
  • @Devrim Did you ever find a solution? Same thing is happening on my 2012 MacBook Air running El Capitan. Other people have reported the same problem here: apple.stackexchange.com/q/209881/38302 – Jim Rhoades Mar 7 '17 at 17:02
  • @JimRhoades yes Jim I have. This lead to another issue which you can follow here + solution is also there... apple.stackexchange.com/questions/263232/… – Abdul Sadik Yalcin Mar 7 '17 at 18:53
-1

If you create a new user account in macOS and that solves the problem, then you have a configuration issue or an app or daemon misbehaving.

If that does not solve the problem, based on the steps you've taken already, check to make sure your router/access point has its firmware up to date.

If it's up to date, you might try resetting it to its defaults.

  • OP stated their using El Capitan, not macOS Sierra. – fsb Sep 30 '16 at 19:21
  • I don't think my suggestions would change? If you think it should be OS X El Capitan but macOS Sierra feel free to edit the answer. – samh Sep 30 '16 at 20:25
  • I created a new user and nothing changed. Issue persists after sierra update as well. But bootcamp is smooth :| – Abdul Sadik Yalcin Oct 10 '16 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .