0

I have strange issue and let me clarify that I am new to Mac.

OS: OS X Yosemite
Browser: Some (Chrome + Safari)

Issue: I am able to open google.com or youtube.com but I can't access a certain site. My machine's firewall is disabled.

I have tried the following so far:

  1. Changed DNS servers: (8.8.8.8, 208.67.222.222 and 208.67.220.220) -> not working.

  2. Ping test: success but still not able to open site.

  3. Another test from Terminal window: curl siteurl and even sudo curl siteurl : No success.

Error Message : Connection refused. ( On Chrome I can see the error code ERR_CONNECTION_REFUSED).

From the above error code I assumed that there might be an issue with the proxy settings but the are blank.

I have another Windows machine with a temporary proxy (Fiddler). Now I have specified this machine address as proxy server.

  1. I have tried to access the previously refused site and it opened successfully.

What is the issue here? What is a solution?

  • Do you want to share the site you have issues? or get a more general answer that you'll need to apply steps to isolate what's up? – bmike Aug 27 '16 at 19:00
  • You can consider any site. – dotnetstep Aug 27 '16 at 22:45
1

Use Network Utility to look up the site:

enter image description here

Verify you can reach ports 80 and 443 (and only use http for when port 80 is open and https for port 443)

enter image description here

Then enter the IP address instead of the DNS name in safari (or whatever browser). If your DNS is not working on the Mac, you can get the IP from another computer and verify the rest of the Mac works and focus on DNS.

| improve this answer | |
  • I have tried this and Port scan and Lookup get success for both google.com and site that does not get response in chrome and safari browser. Even www.apple.com give me error ERR_CONNECTION_REFUSED but in port scan and lookup give me response. I have doubt that some hidden proxy issue but I am very new to mac os. – dotnetstep Aug 28 '16 at 3:09
  • This issue get resolved and issue get resolved after I have installed Anti Virus software and scan entire machine. After that It all start working. – dotnetstep Aug 29 '16 at 5:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .