1

I have a Nokia N900 that's running Maemo (based on Debian Lenny).

I am connecting it to my Mac using USB. On the Nokia I run ifup usb0. In /etc/network/interfaces I have:

iface usb0 inet static
address 192.168.2.18
netmask 255.255.255.0
gateway 192.168.2.17

I connect it to my computer using USB and I get the following: enter image description here

But, when I run nmap on the IP address 192.168.2.17 from my mac with the -sV option it's displaying: 22/tcp open ssh OpenSSH 6.9 (protocol 2.0)

... This isn't the version of OpenSSH that's running on the phone. The version on the phone is 5.1. This is the same version that's running on my mac.

Some how that IP is linked to my mac.

If I use the IP address 192.168.2.18 I get a warning saying the IP address is already used on the network. I've tried changing the IP on the phone in the interfaces file, but it does the same thing each time.

Any ideas what's going on?

netstat -nr from the mac (excluding ipv6):

Internet:
Destination        Gateway            Flags        Refs      Use   Netif Expire
default            192.168.1.1        UGSc          632        7     en1
127                127.0.0.1          UCS             1        0     lo0
127.0.0.1          127.0.0.1          UH              3     5737     lo0
169.254            link#6             UCS             1        0     en1
192.168.1          link#6             UCS             1        0     en1
192.168.1.1/32     link#6             UCS            12        0     en1
192.168.1.1        74:a5:28:f0:f8:9d  UHLWIir       125      258     en1   1186
192.168.1.5/32     link#6             UCS             2        0     en1
192.168.1.5        28:f0:76:4:db:80   UHLWIi          1       16     lo0
224.0.0            link#6             UmCS            2        0     en1
224.0.0.251        1:0:5e:0:0:fb      UHmLWI          1        0     en1
255.255.255.255/32 link#6             UCS             1        0     en1
  • Could you post netstat -nr to a chat room and ping me? Might be a routing issue or just the nmap is looking at the physical interface and not the synthetic tunnel to the phone. Also - we could try to clarify if this is an XY question. – bmike Aug 27 '16 at 17:56
  • @bmike Do I run netstat -nr from the mac? I will append it to the question. – BugHunterUK Aug 27 '16 at 18:07
  • Never mind. Your mac has address 192.168.2.17 so you want to nmap 192.168.2.18, no? – bmike Aug 27 '16 at 18:26
1

Try changing your Mac's IP to match the screen below (default route and net mask are likely wrong).

enter image description here Then run nmap -sV 192.168.2.18

  • That didn't work. Does the router address have to match gateway address on the phone? This is the confusing part. I tried both ways. – BugHunterUK Aug 27 '16 at 18:31
  • You should probably just test with no other network connection. Set the default route for each device to be the other IP address. This is the XY problem I mentioned - you are asking about what you think you need to know about how to solve your eventual problem and aren't asking the actual problem. My guess is you're just struggling with network routing and need a short class or someone to work with you to set up two networks that can route traffic onward. – bmike Aug 27 '16 at 18:32
  • You're maybe right. My knowledge is a little hazy when it comes to networking. – BugHunterUK Aug 27 '16 at 18:37
  • Ask Different Chat might be a good place to explain what "doesn't work" – bmike Aug 27 '16 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .