1

I've been having password problems for the past month or so. I first noticed that I couldn't update Flash because the installer rejected my system password. Today I tried to solve the problem, looking online for fixes, but nothing has worked so far.

  1. Tried to reset my password on the "Users & Groups" System Preferences pane.
  2. Restarted holding Option at the boot chimes > "Recovery HD" > "Mac OS X Utilities" > "Utilities" > "Terminal". Entered reset password on the command line. Kept terminal open. Completed the "Reset Password" pane. "Password not saved. You may not have permission to edit this disk or a general failure has occurred."
  3. Restarted in "Single-User Mode": Command+S at boot chimes. In the command line I entered:

    mount -uw /
    launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist
    dscl . passwd /Users/myusername mypassword
    reboot
    

    After this third attempt, I attempted to install some software and received the following message: "An error prevented the installation of .... Authorization failed. 100022".

I also used Disk Utility on my "Macintosh HD" to verify and repair permissions, which was successful; however, when I tried to verify and repair the disk itself, I got "Incorrect number of thread records (4, 24418)".

I purchased a new SSD and battery earlier this summer, knowing that I would have to clone my existing HDD to the new drive, but now I can't do much of anything without my password. If I could get a working password, I could try to repair my HDD with DiskWarrior.

Here's another question: how can I create a "Repair Disk Partition" on my new SSD, using existing 10.7 software? Here's an article which seems to say the Disk Utility can do it: "OS X: About Recovery Disk Assistant" https://support.apple.com/en-us/HT202294.

If I only had a password! Thank you all in advance for your wisdom.

  • Enable the root account from single user mode. Also dont use dscl but use passwd instead. – John Keates Aug 29 '16 at 2:58
1

Perhaps try enabling the root user from single user mode?

launchctl load /System/Library/LaunchDaemons/com.apple.opendirectoryd.plist
passwd root

https://www.personalmacgeniuses.com/2013/10/31/case-of-the-missing-admin-account/#.V8qUxGW_2AU

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .