0

While going through my settings I wanted to try out the "dark menu bar" in the General System Preferences. Now I cannot turn it off. Each time I uncheck the checkbox, it seems to have no effect, it's stuck in dark mode. I've tried booting into Safe Boot as well to see if i could change it there, to no avail.

This seems to also only be for my user, as switching to guest mode works properly. https://www.youtube.com/watch?v=h6Ga6bXEFEo

Screencast of the issue: https://www.youtube.com/watch?v=xNEHhoFzniI

Machine: OS X El Capitan 10.11.16 MBP Retina 15, Mid-2015

Edit: replaced screencasts with jing to youtube so that non-flash users can view the issues

3
  • Screencast unfortunately requires Flash :/
    – Tetsujin
    Commented Aug 25, 2016 at 16:30
  • 1
    Here's a youtube video instead: youtube.com/watch?v=xNEHhoFzniI Commented Aug 25, 2016 at 19:30
  • Hm...perhaps it's a permissions problem on your Library. That screwed up my system once.
    – SilverWolf
    Commented Oct 19, 2018 at 20:26

2 Answers 2

1

I just tested the following under OS X 10.11.5 and it worked.

  • Go to System Preferences > General and check the [√] Use dark menu bar and Dock check box, then close System Preferences.

  • Copy and paste the following command line into Terminal, then press enter.

    defaults delete .GlobalPreferences AppleInterfaceStyle; killall -HUP Dock
    

After executing the above command line, the Dock momentarily disappeared and a couple seconds later the menu bar was the default color once again.

5
  • Thanks for the reply, but this didn't seem to work. here's a screencast of my attempt: screencast.com/t/d54rD52mLd Commented Aug 25, 2016 at 19:14
  • youtube version of the attempt. youtube.com/watch?v=fAM637YA4Dw i tried both unchecking and checking that before running the command. Commented Aug 25, 2016 at 19:36
  • @dmachiavello, What happens if you use the following command line instead? defaults delete $HOME/Library/Preferences/.GlobalPreferences.plist AppleInterfaceStyle; killall -HUP Dock and do it in Terminal, not iTerm. Commented Aug 25, 2016 at 20:04
  • Looks like the same thing (nothing). Attempt: youtube.com/watch?v=zxS9Lnv-1pE Commented Aug 25, 2016 at 20:11
  • Also, for completeness, i logged into guest mode and was able to prove that it works fine for guest. My suspicion is that it's my user preferences that are corrupted. youtube.com/watch?v=h6Ga6bXEFEo Commented Aug 25, 2016 at 20:23
0

This bug seems caused by how the system determines appearance of menubar. If the wallpaper you used is generally dark, dark appearance would be used for menubar disregarding the current appearance setting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .