Okay so here is the story..

I had just bought this Mac... I tried installing some software, and nothing was installing... kept getting this stupid error.

The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

Displayed like this:

So I thought it was like that for one particular program, so I began looking on the internet. Eventually I just forgot about it, until I tried to install another piece of software. Again the same issue... I soon realized after that it was happening to every single piece of software that I was trying to install that involved an installer package...

So then I tried to download and install El Capitan from scratch... But now I have run into another issue... app store won't download it... I'm stuck with this spinning wheel at the top left corner where the "Back" and "Forward" buttons are with the "Download" button grayed out after clicking on it. No response or any indication that it is downloading.

Displayed like this:

Any ideas? Support is out for the day, so I hope I can get an answer by tonight.

  • More details would be helpful. What software were you trying to install when this first happened? If you bought the computer new then you might want to just take it back to the store. Otherwise you can try restarting the computer in recovery mode. From the Apple website - To start up from OS X Recovery, hold down Command (⌘)-R immediately after turning on or restarting your Mac. Release when you see the Apple logo. If you can't start up from OS X Recovery, try holding down Option-Command-R to start up from OS X Internet Recovery. – I0_ol Aug 25 '16 at 4:09
  • Also you might want to have a look at this question. – I0_ol Aug 25 '16 at 4:12
  • You might also want to give it a few hours - the download is over 6GB. You didn't say how long you left it before running out of patience. Also, check the Launchpad icon in the Dock, that usually has a download indicator under it. – Tetsujin Aug 25 '16 at 7:38

This is not really a true answer. But eventually after attempting to download El Capitan several times, it all of a sudden began to download. Once it downloaded I put the OS on a flash drive, booted off of it, wiped the drive, and performed a clean install. After that the system has been operating flawlessly. I guess when they gave it to me, something must have gone wrong during the install that got overlooked? not sure.

To be honest I do not know what software I was trying to install first when this all began. But it was something simple. This happened to me on every installation of any product that involved using an installation package. i.e. Adobe flash, Teamviewer, my logitech mouse drivers. It was happening on everything I tried to install. I just don't remember the first thing it was I tried to install.

Anyways now it's all up and running after the clean install, and performs flawlessly. Hopefully this doesn't occur to me again.


  • If this answered your own question, be sure to accept it. This will let others who have the same, or similar, problem know that a possible answer exists. – fsb Aug 25 '16 at 19:14
  • Yeah I tried. It says that I can't accept it until tomorrow? – Sicariuxs Aug 25 '16 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .