3

I have a Macbook Pro (Retina) and recently my camera stopped working.

I didn't drop it or anything, it's just not being detected as a hardware.

When I try to see why, System Report shows me:

No video capture devices were found.

I don't have Apple support anymore and I can't find any comprehensive guide or tips for this kind of problem - I just found issues with the camera, but not itself not being detected.

I tried to reset NVRAM and other things such as Diagnose mode, which gave me this error code above:

4HDD/11/40000000:SATA(0,0)

But on subsequent runs of this diagnose mode gives me no error. I also think it's unlike SATA has to do with the camera, as it typically uses USB.

I'm kind of lost and I just want to take it to assistance only if there are no other options, since I need my computer to work.

  • Could the error with the SATA/HD be affecting the Camera, possible a corrupted hard drive? – At0mic Aug 24 '16 at 18:05
  • It's actually a SSD, not HD. But I performed Disk Utility's First Aid and it didn't report anything wrong. If you have any tips on that sense, I would much appreciate @IronCraftMan . – lucasarruda Aug 25 '16 at 15:04
  • ok. Have you tried reinstalling OS X? – At0mic Aug 25 '16 at 21:23
  • No, I haven't, but do you really think that could fix this or are you just trying something different? Also, since I backup to TimeMachine, not sure that reinstaling / restoring time machine backup would change anything. – lucasarruda Aug 25 '16 at 21:28
  • I'm not taking about restoring from time machine. Either re-download the OS X installer or use Recovery HD and just reinstall. My guess is that since you didn't have any physical damage, something may be wrong with the driver. – At0mic Aug 25 '16 at 22:20
1

For anyone experiencing this problem, I would suggest going with System Diagnose + NVRAM reset + SMC reset + Disk repair.

And if none of those work, follow @IronCraftMan advice and proceed with reinstalling OS X - you won't lose any data.

These steps worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .