When I attempt to buy an app but after clicking "GET" button for an app the following happens :

1. "GET" text becomes "INSTALL"
2. I click "INSTALL"
3. "INSTALL" becomes loading image
4. loading image disappears and "GET" text is displayed.

The app is not installed.

Not sure if related but this seems to have occurred since updating ipad to latest ios version - 9.3.4(13G35).

  • What app are you trying to download? It could be that it is not compatible with your device. For example, if you look at iBooks on the App Store, it's only compatible with iOS 10 and above. This is weird, since iOS 10 isn't out yet. But it's true!
    – TMHahn
    Aug 24, 2016 at 17:24
  • @Frsk it appears to be all apps, as ive tried approx 10, as an example this is occuring for 'Calculator Free'
    – blue-sky
    Aug 24, 2016 at 17:26

1 Answer 1


First, try restarting your device.

Second, try doing a forced-restart by holding the power and home buttons down at the same time until the Apple logo appears, and then release (this should only be done in desperate times, not as usual practice).

Third, follow these steps: (which can be seen on this site)

  1. Go into the App Store.

  2. Across the bottom, you will see a white bar.

  3. On the far left, you will see a star and the word "Featured."

  4. Tap the star 10 times. You will see the screen flash white momentarily.

  5. Restart your device again.

Then try to download the desired app again.

  • second option worked. muchas gracias , saved me alot of time!
    – blue-sky
    Aug 24, 2016 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .