1

I'm using El Capitan on my Mac Mini now but it started when I used Yosemite. I need both English and Russian keyboard layouts on my Mac. However at some point I started finding Russian layout missing once Mac is launched, so I have to go to the settings and add Russian again every time my Mac starts. Did anybody encounter a keyboard vanishing from the system constantly? What makes it dissapear every time Mac is shut down? Ayn ideas how to fix that?

  • By "language" you mean the keyboard/input source, right? Your OS interface is English? – Tom Gewecke Aug 24 '16 at 11:18
  • Yes, this is what I mean. No, my OS is Russian. Is it the case? – Andrey Chernukha Aug 24 '16 at 11:34
  • Did you set Russian as your primary keyboard when you first set up your Mac? – Tom Gewecke Aug 24 '16 at 13:51
  • Try going to system prefs/keyboard/input sources and adding some other keyboards besides US and Russian, such as French and German. Do they all disappear when you restart? – Tom Gewecke Aug 24 '16 at 13:52
  • my primary keyboard was English. I also tried adding German, it vanishes as well, along with Russian. my Mac loves English only. Can't stand other languages – Andrey Chernukha Aug 25 '16 at 13:39
1

Go to System Preferences -> Language & Region.
Set English as Preferred language. Unfortunately, your macOS becomes English, but it's the only way that solved this problem on my Sierra 10.12.5.

0

You could also try to delete ~/Library/Preferences/com.apple.HIToolbox.plist, /Library/Preferences/com.apple.HIToolbox.plist, or ~/Library/Preferences/ByHost/com.apple.HIToolbox.*.plist.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .