0

Trying to setup Wifi on Kali Linux 4.3 for Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

I keep getting stumped with the 'modprobe: FATAL: Module wl not found.' error

Any help would be greatly appreciated !!! Details of steps and output below:

root@kali:~# cat /etc/apt/sources.list  
deb http://httpredir.debian.org/debian/ jessie main contrib non-free  
root@kali:~# uname -a  
Linux kali 4.3.0-kali1-amd64 #1 SMP Debian 4.3.3-5kali4 (2016-01-13) x86_64 GNU/Linux  
root@kali:~# id  
uid=0(root) gid=0(root) groups=0(root) 
root@kali:~# lspci -nnn | grep Broadcom  
02:00.0 Multimedia controller [0480]: Broadcom Limited 720p FaceTime HD Camera [14e4:1570]  
03:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)  

root@kali:~# apt-get update  
Ign:1 http://debian.mirror.constant.com/debian jessie InRelease  
Hit:2 http://debian.mirror.constant.com/debian jessie Release  
Reading package lists... Done  
root@kali:~# apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms  
Reading package lists... Done  
Building dependency tree       
Reading state information... Done  
linux-headers-amd64 is already the newest version (4.6+74+kali1). 
broadcom-sta-dkms is already the newest version (6.30.223.271-3).  
linux-image-amd64 is already the newest version (4.6+74+kali1).  
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.  
root@kali:~# modprobe -r b44 b43 b43legacy ssb brcmsmac  
root@kali:~# modprobe wl  
modprobe: FATAL: Module wl not found.  

I've tried multiple iterations and continue to get stuck on this
modprobe: FATAL: Module wl not found. error.

1

I was having the same problem, and finally found a way to fix it. Run this script that download the necessary headers the missing module.

https://gist.github.com/speeddragon/2d4ea420a8a53407cb8218fa28c2a74b

I didn't test the script, but it should work.

The issue is the following. Kali doesn't show available the 4.3.0 linux-headers and necessary packages (like kbuild) to build the module when you install "broadcom-sta-dkms".

After install the necessary things for 4.3.0 kernel, you install the "broadcom-sta-dkms" again and "modprobe wl" should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .