I started experiencing problems after playing with hotspotshield.com,
it may have done something to the core apple connection preferences.

I have looked all over the internet and I can't find a solution..

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

Here are my specs - Lion 10.7.1

do you have any other connectivity issues and did you knowingly change any network configurations when you were using hotspotshield?

  • I had no other connectivity issues beforehand and no i didn't change any network settings to my knowledge.
  • I've tried connecting thru Ethernet, Wi-Fi, and iPhone USB tethering. The internet does work, but the software update and app store will not connect.
  • I created a new user to test it and it doesn't work..
  • Per the new image added, the badge does get updated, but it isn't allowing access..
  • How are you connecting? Wi-Fi? Try over ethernet. Also, make sure the VPN client isn't running as this will stop any packets from getting through / going out unless it's through your VPN tunnel.
    – ingh.am
    Commented Sep 17, 2011 at 1:36
  • I've tried connecting over several mediums.. how do I check on a VPN client? Commented Sep 17, 2011 at 22:46
  • Question updated Commented Sep 17, 2011 at 22:51
  • Do you have any VPNs listed in Settings -> General -> Network -> VPN ? Commented Sep 17, 2011 at 23:51
  • What version of iTunes are you using? iTunes updates a number of core components needed for the app stores. Commented Sep 17, 2011 at 23:55

5 Answers 5


1) Have you tried:

defaults read /Library/Preferences/com.apple.SoftwareUpdate > ~/Desktop/su.dwrites.txt

defaults delete /Library/Preferences/com.apple.SoftwareUpdate

(The first line will save your SoftwareUpdate settings to a file, the second will delete them.)

2) Check




to make sure that there's nothing in there which is mucking with your network settings.

If you find anything that you aren't sure about, try moving it to your Desktop and then reboot.

3) If that still doesn't do it, check netstat -rn to see if it's showing anything odd.

Updated 2011-09-20 to add:

Ok, so it appears that didn't help.

Other possibilities:

sudo mv /Library/Preferences/com.apple.SoftwareUpdate.plist ~/Desktop/

and reboot to make sure that those settings have been removed.

I'm not sure how this is effecting only Software Update and the Mac App Store.

Two more commands:

networksetup -getwebproxy Ethernet

networksetup -getwebproxy Wi-Fi

(depending on which one you use to connect)

They should output something like:

Enabled: No
Port: 0
Authenticated Proxy Enabled: 0


This almost seems too simple to suggest, but for the sake of completeness: have you tried creating a new "Location" in System Preferences >> Network?

By default it will be "Automatic" but if you click it, there should be an option to "Edit Locations".

Try creating a new one and switch to that, then try again.

  • I tried running the 2 linesin terminal, it didn't do anything.. Commented Sep 20, 2011 at 13:49
  • I removed the contents of all my launch items folders and logged out/in but it's still not working.. Commented Sep 20, 2011 at 13:49
  • I ran the netstat command and this is what I get.. see.weareinto.com/AHGf Commented Sep 20, 2011 at 13:50
  • The terminal commands would not have any output. The first one saved your current settings to a file, and the second one deleted/reset your Software Update permissions.
    – TJ Luoma
    Commented Sep 20, 2011 at 21:48

Interesting. If you are on Lion, which you seem to be from the screenshots, then you can first try:

man 8 softwareupdate

softwareupdate -l 

Would ordinarily list your available updates. But wait! Open another tab and in this one you are going to use the handy nettop(1) command

Just type "nettop" and see what it says. Do not quit, use down arrow to see the bottom, use left arrow to summarize. Do not quit.

Now run

softwareupdate -l and see if anything proper happens _on the nettop tab_. ( Paste it here I guess ) 

The first thing we can try with lion until the next os:

man sysdiagnose  # handy as a gun in a knifefight

There will be no secrets, I believe.


man 8 tmdiagnose
man 8 mddiagnose # spotlight 

This is a painfully obvious thing to ask but,

did you try looking at the Console.app? Or typing


to see what osX thinks the problem is ?

syslog -F raw -w 20.

will make it act like tail -f

Finally, you can reach for the rum, the chalk, and the chicken and use, if you are using wi-fi that is:

airportd   #there is no man page for this

airportd prefs  # see what is set

airportd readNVRAM # see what your fallback network is set to.

Have you tried rebooting and holding down cmd-R, to get to the recovery partition? The main drive is not mounted, it's very cool, assuming you did not have a custom partioning scheme...

  • Wow ! awesome, working thru it.. looks like the app store and software update are having problems see.weareinto.com/AGd5 Commented Sep 20, 2011 at 13:31
  • kirkstrobeck:~ kirkstrobeck$ man 8 sysdiagnose No entry for sysdiagnose in section 8 of the manual Commented Sep 20, 2011 at 13:33
  • I think I have some progress.. when using the line softwareupdate -l the other window does show a connection see.weareinto.com/AGvp Commented Sep 20, 2011 at 13:35
  • Here are the messages I get when launching appstore.. see.weareinto.com/AGvR Commented Sep 20, 2011 at 13:39
  • sysdiagnose is in section 1, man sysdiagnose is sufficient. man 1 sysdiagnose works too if you really want to be explicit :). Commented Sep 20, 2011 at 18:01

Hotspot Shield comes with an Uninstaller. Did you run it, and did that solve your problem? Once you run the uninstall, you should reboot your machine.

We use VPN services (paid, I'm afraid) from Witopia and Hotspot VPN (we're trying both services for a year to see which we like better). I'm the one with Witopia, and I use OpenVPN on my MacBook, and have a choice of Cisco IPSec or PPTP on my iDevices. No problems with any of these.

  • I did run the uninstaller and restart.. first thing I tried.. :( still hasn't fixed my issue Commented Sep 15, 2011 at 3:11

In /System/Library/CoreServices there is a Network Diagnostics app that should look like this:

Network Diagnostics

Give that Wizard a try to see if it helps you fixing your networking. I'm sure there's got to be something weird going on.

UPDATE: ok, since you have already tried a lot of things (suggested by various users across the board), let's try something different.

Could you post a screenshot of the following screens.

System Preferences -> Network

System Preferences -> Network -> Advanced (bottom right corner, make sure you have the right connection selected)(*) -> And then I'm interested in three screens:

  • TCP/IP
  • DNS
  • Proxies

Feel free to add anything else you see fit.

network pane

Additionally, I'd suggest you disable Little Snitch (I have it too and it's great, but at this point in can only add problems rather than help fixing them).

Download a free trial of Charles Proxy so we can analyze what your outgoing traffic is attempting to do.

That should keep you busy for a few minutes while I finish my Coffee ;)

(*)Yeah, i was having a Tantalizing Turkish Coffee @ Philz in SF ;)


A few things to try

Here are a few things you could try to get your networking settings working again.

Try Signing Out

Try signing out by selecting "Sign Out" from the "Store" menu and then logging back in.

Check the preferences in Keychain Access

  1. Open Keychain Access
  2. Open Keychain Access Preferences
  3. In Preferences window select the certificates tab
  4. The first option: "Online Certificate Status Protocol" select "Best Attempt"
  5. The second option: "Certificate Revocation List" select "Best Attempt"
  6. Leave the third option alone. It will most likely be set to OCSP.

enter image description here

Try deleting some App Store preferences and caches

You can safely delete the App Store preferences as they will be recreated the next time you use the app. Here's what you should do:

  1. Quit the App Store
  2. Delete the file at ~/Library/Preferences/com.apple.appstore.plist
  3. Delete the file at ~/Library/Caches/com.apple.appstore/Cache.db
  4. Delete the file at ~/Library/Cookies/com.apple.appstore.plist
  5. Delete the file at ~/Library/Cookies/Cookies.plist
  6. Logout & Login
  7. Restart the Mac App Store

Upgrade Little Snitch

If you have Little Snitch installed make sure that it is fully up-to-date. The current version is 2.4.2 and the release notes say that 2.4.1 fixed "an incompatibility with Mac App Store and Software Update."

Also because Little Snitch can mess with a lot of basic networking services (even if you don't think it is) try uninstalling it to be absolutely sure that it isn't conflicting.

Please let us know which, if any, of these solutions helps with your issue.

  • Great tips, but just did all of this and it didn't work :( Commented Sep 18, 2011 at 4:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .