6

I'm disabling the cache from Safari developer menu, but each time I reboot my computer, the cache is re-enabled.

I'm looking for a permanent solution for disabling the cache.

Any ideas?

3
  1. Empty the cache from the Develop menu.
  2. Quit Safari.
  3. Lock ~/Library/Caches/com.apple.Safari/Cache.db from Finder's Get Info inspector.

This prevents Safari writing to the cache.


If you're here looking for how to disable cache now the option mentioned in the question is removed in Safari 11, see How to disable all caches in safari 11?

  • this is not working for me. Safari is still caching on the twilight zone. I have renamed all Cache.* files on the directory and created zero byte versions of them using touch then locked these 0 byte versions using chmod 000. Safari is still caching probably in memory, because the files continue to be 0 bytes. – SpaceDog Sep 28 '17 at 4:06
  • @Space I doubt this Q&A is what you’re looking for, see the link to the question regarding Safari 11. – grg Sep 28 '17 at 7:43
  • not working too. :( – SpaceDog Sep 28 '17 at 8:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .