2

I was using Terminal and accidentally fat-fingered some shortcut. The apparent result was the window was destroyed and all of the running processes (some local dev server processes running in the foreground) were put into the background. I tried everything I could think of to find the window (e.g. mission control), but even after quitting Terminal completely the local server processes are still happily running. What did I do, and is it reversible (barring reboot)? The processes were ruby and node processes if that's somehow relevant.

Edit: I forgot to mention these processes were running from inside tmux.

1

Ah, the thing I forgot to mention turned out to be the most critical. Opening a new window and running tmux attach -t 0 fixed it.

Thanks to https://unix.stackexchange.com/questions/22781/how-to-recover-a-shell-after-a-disconnection.

Must have closed the window with command-w.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .