2

When I try to scroll up and down a sheet there is substantial delay. Using the keyboard arrows to navigate is also incredibly slow. I have no graphics or complex formulas. Just 10 columns of plain text and about 300 rows.

I'm using a registered version of office 2016 (for business) and Mac OS 10.11.6 (El Capitan).

This slow down appears when connected to the Internet.

  • Can you attach a copy of your workbook? (Edit out any sensitive data first!) – D A Vincent Aug 22 '16 at 11:30
  • 1
    There can be any number of reasons, but first, you should see if your .xls file is corrupt. Try copying just the cells and their content to a new spreadsheet and see if that fixes the problem – Allan Aug 22 '16 at 12:18
  • just create any excel file with data. Issue is not data related. It will get slower and slower. I believe one first has to be offline, then open the app. Then connect to the internet. See my answer below that has links to users with similar issues. – DynamicDan Aug 22 '16 at 13:25
  • I can't replicate the problem (Excel 2016). I have a worksheet with 50K cells and 35 columns. I am not seeing any slowdown and I am continually working "online" as this data is stored on OneDrive. – Allan Aug 23 '16 at 10:44
4

When I had a similar problem, disabling dropbox integration (I never realized I had enabled it) made a huge difference in performance, especially for otherwise trivial things in Office/Excel like copy and paste (which had become unbearable).

System Preferences->Security & Privacy->Privacy Tab->"Allow the apps below to control your computer" (dropbox was checked, I unchecked it). Not sure exactly what functionality this took away from dropbox, but it still syncs folders fine, which is all I used it for anyway.

(I know this is thread is over a year old, but it's one of the first results in Google so I'm adding this for all the others who come along in hopes it may help them).

3

I add excel to Accessibility, and it works fine for me, also I don't have Dropbox installed on my mac

2

I believe there is an out of control process causing this that needs to be force quit to get performance back to normal.

Here are my online findings on the topic:

The comments hint towards too many "open ports". Force quitting the excel process via activity monitor with the most ports seems to do the job. I suspect this is a registration connection issue..

Office tries to constantly connect home and check that the product is registered. If you are offline and then go online then the issue occurs. I'm guessing these open ports are in reference to internet connections to a registration server.

2

Select "normal view" instead of "page view". This is located in the lower right hand bar. Page view seems to have issues and be very slow.

2

I had the same problem with Office 2016 & MacOs High Sierra.

it was nearly 20 second to open Excel, and 15 second to open Word. Then I did:

System Preferences > Security & Privacy > Privacy Tab > Accessibility

I removed Dropbox from there, then opened Excel (or Word). When it ask to you for permission Dropbox, said No & Do not ask again.

Its now 3 seconds for Word and 5 second for Excel. Not the best but better.

2

This doesn’t answer the OQ because of the lack of technical details to pin point the origin of the problem. This is rather a general advice to get a more sure and performant working environment.

I suggest you to install LibreOffice.

Open your file with it and compare your time to make a well defined scroll for example along 10 full pages, with just the arrows to limit human error.

The bigger is your benchmark files the more accurate will be your comparison.

1

Unfreeze Pans/Rows, it seems Mac can't deal with it for some reason. Works for me

0

I have Office 365 Excel 16.10 running on High Sierra (10.13.3). Copying takes several seconds, sometimes cell comments are not viewable at all & often my previously working Hyperlinks to other files in the same folder don't work. Neither unfreezing pans/rows, adding Excel to System Preferences > Security & Privacy > Privacy Tab > Accessibility nor using Normal View (my standard anyway) made any improvement in its performance. I didn't have Dropbox in my Privacy list. Disconnecting from the internet improved the situation, however. Copying is a little quicker, although viewing comments and using Hyperlinks are still unreliable. I have to say that I don't consider this a practical solution, merely a workaround while waiting for Microsoft to fix the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .