0

I tried to install an authorization plugin on mac OS X 10.7 that previously worked on Snow Leopard but all I'm getting is a white screen with the cursor. Did something happen to authorization plugins in Lion? Is there a way to fix this?

PS. Something definitely changed considering the way it looks now.

  • Not according to Apple's revision history. Are you sure you built it for the right architecture (x86_64 and i386)? – Ingmar Hupp Sep 14 '11 at 13:42
  • Yes this plugin previously worked on a machine running snow leopard in both x86_64 & i386. It stopped working when I upgraded to Lion i.e. the machine is the same – Samantha Catania Sep 14 '11 at 13:44
  • What do the logs say then? – Ingmar Hupp Sep 14 '11 at 13:52
  • SecurityAgent: Problem during create from: (file) file is the name of where the code for the plugin is located – Samantha Catania Sep 14 '11 at 14:28
  • 2
    I did some research and I found out that plugins having a GUI shouldn't be set as privileged. – Samantha Catania Sep 14 '11 at 15:01
0

Removing all the custom GUI from the plugin solved the problem

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .