1

Last week I started having problems with my Mac (a mid-2010 Mac Pro running OS X El Captain), after searching for the cause I realized my OS X partition was corrupt.

A while back I turned on FileVault, and 2-3 weeks later all of a sudden my Mac started slowing down. In the end, 5 minutes after booting up my Mac simply froze, I wasn't able to do anything any more.

I decided to reinstall OS X but to my horror I realized that I couldn't select my original disk any more. No matter what I tried (I even booted up using a Windows 10 install disk to remove all the partitions on the disk) , I couldn't get OS X to reinstall on the same disk.

I finally gave up, installed it on the 2nd disk, installed Paragon Hard Disk Manager which allowed me to finally create a new partition on the disk, and started using it as a data disk.

I thought I had solved the problem, until I wanted to turn on encryption on the disk. I got an error message, which Google told me meant I didn't have an EFI partition on the disk.

So I googled around for a solution, found one but it made everything worse. Now even Paragon Hard Disk Manager can't create a working partition any more.

So... How do I clean up this mess? I have a working OS X install, I just want to create another partition on my other disk and encrypt it...

How can I fix this?

Output sudo gpt -r show disk1:

       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34        2014         
        2048  1953519616      1  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  1953521664        3471         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header

When I first executed diskutil list the list said there was a "Microsoft Basic Data" partition" on the disk. Probably the partition Paragon app tried to create:

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE               IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:       Microsoft Basic Data                         1.0 TB     disk1s1

I'm not certain the disk isn't failing, but my current problem started after me trying to recreate the EFI partition, so I'm assuming it's still a logical problem rather than an actual hardware problem.

  • 1
    How certain are you that the drive itself isn't failing? – Tetsujin Aug 21 '16 at 11:10
  • Please start Terminal.app and enter diskutil list. Now search for the disk identifier of the stubborn internal disk (e.g. disk0). Enter sudo gpt -r show diskX (with diskX: the disk identifier of the internal disk) and add the result to your question by editing it. – klanomath Aug 21 '16 at 12:27
0

To enable FileVault on a non-system disk you need an EFI partition, an HFS+ volume and a Boot OS X partition. The last one will be built while enabling FileVault.

Your disk contains none of them.

Open Disk Utility (in /Applications/Utilities), choose the appropriate disk (not any inferior volume!) and hit erase in the toolbar.

Choose a name, "OS X Extended (Journaled)" as format and "GUID Partition Map" as scheme. Then hit the erase button.

If the partitioning fails, close Disk Utility and open Terminal.app. Enter diskutil list. Then enter sudo gpt -r show diskX with diskX: the disk identifier of the stubborn disk. Below I assume the identifier is disk1.

If you are sure that you have chosen the stubborn disk (I.e. the one with the 2048 1953519616 1 GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7 partition) enter:

diskutil umountDisk disk1
sudo gpt destroy disk1

Enter exit to terminate the Terminal session and quit Terminal. Open Disk Utility again and repeat the steps to partition the disk mentioned earlier.

  • Since I already tried to recreate the partition using the Disk Utility I skipped this part and immediately went to the next step. After executing the commands and rebooting my system I finally maged to recreate my partitions :) – Fysicus Aug 21 '16 at 22:24
  • @Fysicus The hardware of your disk may still be corrupted though. I try to find an appropriate tool. I'm using a tool called Scannerz, which isn't free. – klanomath Aug 21 '16 at 22:27
  • I'll run a scan then. I just hope I don't have to replace my disk. :( – Fysicus Aug 22 '16 at 6:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .