MacBook Pro 8,1 (13", i5 2.3Ghz) - when I connect an external screen through a MiniDP -> DVI adapter the Mac detects it (knows it's a Samsung SyncMaster and lets me change its resolution) but doesn't show anything on screen. Even though the Mac thinks that the screen works properly (I can move the cursor out of the Mac's screen), the external monitor's led blinks as there was no signal at all. Changing screen resolution doesn't help.

I've browsed many similar questions on the internet, unfortunately most of them suggest upgrading the OS. I'm using Mac OSX 10.6.8 Snow Leopard. What should I do?

  • Have you had this display working with another system? Have you had the Mac and display adapter working with another display? When you reboot the mac, during the boot process does the external display show anything?
    – macaco
    Commented Sep 14, 2011 at 12:01
  • Works with my another computer, doesn't show anything during the boot.
    – Paul
    Commented Sep 14, 2011 at 12:56
  • Did you try the MiniDP->VGA? Another thread is, I have later 2008 MBP 15", with two display chips (one is built in with shared memory). If I connect it to an external monitor, but using the built-in display chip, the external monitor doesn't have any signal. If I switch to the stand-alone display chip, it then works fine.
    – kukoo
    Commented Sep 14, 2011 at 15:06
  • Thanks for this thread folks. Very close to what I am experiencing with my 17" MBP. Just started today. I plug in my external monitor (a company issue NEC) and the MPB monitor disappears. I cannot move the cursor to the MBP monitor. I unplug the external monitor and it switches back to internal. I tried detecting displays with both plugged in but it won't pick up the internal screen, only the external NEC (an accusync LCD223WXM). Thanks in advance.
    – Greg
    Commented Feb 9, 2012 at 14:06
  • today had same problem, old macbook pro 13" - 10.6.8 MiniDisplay - DVI to 23" Apple cinema was not working until the macbook was running 10.9.5 same monitor was running perfectly on old MacPro (1st generation) running same Mac OS X 10.6.8...
    – MrBelloNLD
    Commented Jul 11, 2017 at 18:17

9 Answers 9


I had the same problem, and I think I found what causes the problem. My macbook air was detecting the display, but only thing I saw was black screen.

Either your monitor is using VGA signal even if you are using DVI cable or you are using DVI to VGA adapter in between. MiniDP to DVI only produces digital signal.

For more information check a blog post of mine.

  • I should give credit where credit is due. Your answer is right - I was using a MiniDP to DVI adapter, and then another one, DVI to VGA. That caused the problem. Connecting a DVI monitor to my MBP resolved the issue.
    – Paul
    Commented Nov 8, 2011 at 16:31
  • an upvote is fine too :) I am glad it helped
    – nimcap
    Commented Nov 8, 2011 at 17:37
  • Would upvote the answer, unfortunately I'm not allowed to as I'm not a registered user.
    – Paul
    Commented Nov 9, 2011 at 9:31
  • 1
    Be sure that the cable is pushed in all the way, too. Sometimes a partially plugged-in cable will be recognized by the system without displaying any content.
    – wesk
    Commented Jan 9, 2018 at 21:35

This most likely means the Mac is outputting a video mode that the screen can't display. Try reducing the resolution and Refresh Rate (in System Preferences -> Display) until you get something on the screen, then work your way up the list again. A good starting point would be 1024x768 or even 640x480.

The other possibility would be that the signal isn't arriving intact, either due to a cable/plug fault or that the screen or Mac have a hardware fault (which you can rule out by connecting the Mac to another DVI screen with the same adapter and by connecting the monitor to another computer).

  • 1
    Even at 640x480 the external monitor receives no signal. I've just tried rebooting my mac with no luck - no signal during the boot process. The screen works just fine with my old Mac Mini. Tomorrow I'll try the adapter with another monitor.
    – Paul
    Commented Sep 14, 2011 at 12:55
  • When testing, make sure you test the same input, in case it's a monitor with multiple inputs (just because the VGA input works doesn't mean the DVI input also does). Commented Sep 14, 2011 at 13:33
  • Reducing refresh rate to 30 Hertz (down from 60) worked for me. Thanks!
    – sdgluck
    Commented Aug 31, 2021 at 18:29
  • For future readers, be sure to give the monitor lots of time after each change. I found that if I tried one resolution on the monitor, then switched to the laptop display and changed the resolution (ie. "Use as") from default to More Space, and then down to Larger Text, and then back to default, that took long enough (and forced my monitor to refresh) so that I could actually see a resolution work. Without that I was trying working resolutions, but I thought they were failing, because I saw the black screen for a few seconds and mistakenly went on to the next resolution before it worked. Commented Dec 5, 2023 at 17:20

I've had the problem as well and only by resetting my monitor am I able to get it to work.

Other posts suggesting it is something to do with the PRAM, but I've not seen the problem being on the Mac end of things. As this problem is persistent, so it seems I will have to reset the monitor each time so it recovers from the failure, but doesn't seem to address the root cause so I have yet to find a more permanent fix.

  • It never occurred to me that I need to reset my Samsung SyncMaster 2494LW monitor. I been trying to read various posts & solutions of the last hour. I was ready to give up when I read that you recovered from this failure (at least temporarily) by resetting. I tried & now I am able to enjoy my old external monitor with my MBP 13". Thanks!
    – user52357
    Commented Jun 30, 2013 at 5:41
  • This helped me. Unplugged the monitor from power for 15s, plugged it back in, suddenly it works.
    – jcollum
    Commented Feb 17, 2017 at 21:28
  • 1
    @jcollum You are a hero!
    – gokcand
    Commented Sep 6, 2018 at 11:37


The display worked before. Then without reason it gone black and didn't wanted to show anything. DisplayManager from Mac showed the displays without problem and I could change all settings - for no difference.


Remove everything (in my case ethernet and 2 USB devices) from the adapter und replugged the HDMI.
After that it worked again. And could connect the other cables again aswell.

My setup

MacBookPro 15" and 3x HP_Z32n via a QacQoc adapter from HDMI to USB-C. I have 3 external displays connected and use the internal one aswell. enter image description here

  • Thanks, that worked for me. I had a similar setup with a Panamon dongle and nothing worked until I disconnected everything from the dongle and then reconnected.
    – stone
    Commented Jan 3, 2019 at 22:50
  • This was worth a shot, but did not work for me. My setup: Macbook Pro 2012 -- (TB2 cable) --> TB2/TB3 adapter -- (TB3 cable)--> CalDigit TS3+ -- (TB3 cable) --> 4K display.
    – ijoseph
    Commented Nov 28, 2020 at 23:37
  • 1
    Worked for me with a similar dongle. But is there an explanation for what is going on? I just moved from Windows to MacOS and believed that "Mac just works", but now I keep struggling with very basic issues like this one... Why does the Mac need this kind of unplug and replug exercises?
    – Christoph
    Commented Feb 22, 2021 at 9:31
  • Thanks, I solved with using the dongle as the only external source (By connecting the power supply with the dongle as well, not directly to the MBP).
    – louielyl
    Commented Sep 22, 2022 at 0:42
  • I had a similar issue with the Anker 555 USB-C Hub. After using it on Mac, then plugging in a Windows laptop, then the Mac again, the second monitor got a signal but displayed no visuals. The solution was to unplug the Hub itself, and give it 10sec, and plug it in again. This reset the Hub and then the monitor came through aok! Commented Dec 30, 2022 at 19:48

I solved my problem so far by installing this app (Display Menu) from the Mac AppStore. The screen flashed and I got image.

It might not work for you, but worth the try.

  • 1
    Nice app but it didn't work for me (Non-R MBP 13" 2012, Dell U2417H via DP to MiniDP wire). The system sees it connected but the screen is black and the monitor says no DP signal.
    – Nookeen
    Commented Oct 8, 2019 at 22:58
  • I know this was written a few year ago, but I feel the need to thank you Rui! Today I got a new miniDP to hdmi adaptor. That was the 4th of 5th that I've bought. Even though the ew adaptor is active, everything looks good after installing this program :D
    – astromath
    Commented Apr 2, 2020 at 13:52
  • Screen flashed and I got the black screen of death.
    – Jay
    Commented Dec 9, 2021 at 18:03
  • Didn't recognize my LG monitor I have connected.
    – Patrick
    Commented Dec 18, 2021 at 18:41
  • worked for me, buddy!@Rui :)! thanks a lot, it was festering since few months!
    – bandejiya
    Commented Apr 22 at 14:45

I had the same problem. I reset my monitor to the factory setting and this solved the problem.

  • 1
    Consider expanding on your answer and providing links and/or references to support your solution.
    – Allan
    Commented Apr 26, 2016 at 19:48
  • Awesome, this actually worked! I also found out why; DisplayPort 1.2 was turned on. This enables MST, which is only supported by some very specific Macs, and the newer models are not on that list. If a device does not support MST, the screen stays blank. That's why all DisplayPort monitors have this option turned off by default, and why they give you a big fat warning when you turn it on. I would post more details in an answer, but don't have enough rep for that.
    – iFreilicht
    Commented Feb 25, 2023 at 16:48

Same problem here. Using dell 1920x1200 monitor connected to RMBP 2013 in clamshell mode with nvidia card.

If I open RMBP and check the display preferences, it shows TWO display settings, one for the built-in and one for the 1920 monitor. I can change the res. But external stays black all the way. Log out and log in again does not help.

Rebooting the RMBP helps right away. No need to mess with the monitor or cables. This is purely a software problem in the RMBP.

  • 1
    I have the exact same problem and it's really annoying. Hard to believe this issue still hasn't been fixed 6 years later.
    – Janosh
    Commented Feb 16, 2020 at 17:44

I had a black screen for quite some minutes now and I found out that the monitor, even though it is brand new, does not automatically switch to the active input channel. So choosing the input channel manually on the monitor fixed the problem for me.


Try another HDMI cable. That's what worked for me. I first had a 'normal' one which didn't work. When I switched to one that has 'High speed Wifi E thernet" on it, it works.

  • This is what I came here to say! My screen would remain black or unresponsive only sporadically and I tried every solution I could find. One £8 cable later... and it's fixed.
    – RedYeti
    Commented Sep 12, 2020 at 7:53
  • @RedYeti would you care to share details of the cable?
    – Rob
    Commented Feb 20, 2021 at 23:24
  • @Rob It was simply a replacement cable from Amazon UK. Nothing special about it. I'm glad you asked this though because although this totally fixed the problem for about a month, it then would sporadically happen again. Then I updated to Mac OS 11 and the problem has almost completely gone again. Just now and again it will return.
    – RedYeti
    Commented Feb 22, 2021 at 9:04
  • @Rob Oh, you may have been asking about the 'High speed Wifi E thernet" which was mentioned. I'd missed that in fact. Mine is simply a cable that fits my monitor and MacBook.
    – RedYeti
    Commented Feb 22, 2021 at 9:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .