I tried to install chromedriver using homebrew and got the following error.

$ sudo brew install chromedriver
==> Using the sandbox
==> Downloading https://chromedriver.storage.googleapis.com/2.23/chromedriver_ma

curl: (35) SSL certificate problem: Couldn't understand the server certificate format
Error: Failed to download resource "chromedriver"
Download failed: https://chromedriver.storage.googleapis.com/2.23/chromedriver_mac64.zip

I updated the curl to version 7.50.1 (x86_64-apple-darwin15.6.0) using homebrew and link it but no luck.

My os is OSX 10.11.5 and curl -V result is following :

$ /usr/bin/curl -V
curl 7.43.0 (x86_64-apple-darwin15.0) libcurl/7.43.0 SecureTransport zlib/1.2.5 Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp smb smbs smtp smtps telnet tftp

Any advice would be appreciated.


2 Answers 2


Your curl is using SecureTransport which is using macOS builtin version of SSL which likely be incapable of outgoing encrypted web communications, instead of OpenSSL.

So try reinstalling curl via Homebrew with the following options to support OpenSSL:

brew reinstall curl --with-libssh2 --with-openssl

Note: Paste above line into the Terminal.

Related: cURL fails with error: Couldn't understand the server certificate format.


Open chromedriver_mac64.zip in your browser. If you see this message:

  <Message>Access denied.</Message>
    We're sorry, but this service is not available in your location

Then Google is restricting your access. Simply download that file with an alternative network/IP/location. Then move the file to ~/Library/Caches/Homebrew/ or /Library/Caches/Homebrew/ due to the installation of Homebrew. Then try to reinstall. Homebrew will use downloaded file.

Alternatively you can use a network proxy in the terminal while running brew command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .