I have a third-party NAS drive (Western Digital MyBook World II) which I used for time machine backups in Snow Leopard. I've upgraded to Lion and the first backup has spent over an hour 'Verifying Backup...', what is OS X actually doing here and if I choose to skip verification what are the consequences? It seems to be stuck on 69%...

  • 1
    Do not skip it. You may jeopardize the integrity of your backups, and it will likely repeat the process next time it begins a backup. As for what it does, it checks the integrity of your disk and I believe the filesystem structure (which can take a while depending on how many backups you have or how large it is). Bear in mind that it is dealing with 100,000s of files. – user10355 Sep 14 '11 at 1:01

If it's your first backup in Lion, you need to leave the computer awake and connected to the Time Machine volume and let it do its thing, perhaps overnight. Once it makes an initial backup it has to construct an elaborate index database so that the Time Machine restore functions can work correctly. If you interrupt or cancel the process, it will have to start over from the beginning again at some other time, and this will indeed take up time and system resources. I have heard complaints from others that the initial backup, verifying, indexing, etc. takes a great deal of time in Lion, but you need to allot the time necessary to let the system do its thing in order that it work correctly.

  • Any details/references on that elaborate index database? Is that a new thing in Lion? – Thilo Sep 14 '11 at 10:05
  • I can provide no details or references. I don't think it's a new Lion thing, but I have observed that Lion takes more time to do it than Snow Leopard or Leopard did. I don't think there's much that a user could do to influence this behavior. – user9290 Sep 25 '11 at 15:55

I've had this same issues on later versions of Mac OS X, including Yosemite. What's happening is that the system is running fsck to check the integrity of the backup.

Found a solution here. Basically, to get around it, go to System Preferences, and set the sleep time to 3 hours or longer. Per some of the other posts, the long time may be needed for some cross-linked files.

After modifying the sleep time, my backup issues were solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .