9

OS X EI Captain (version 10.11.5). This issues is consistent, whenever Mac awakes from sleep, My internet is disconnected. I tried the following options,

  1. Turn off wifi and turn back on.
  2. Restart network service by sudo ifconfig em0 down and up.Basically restarting network services.
  3. Network settings to renew DHCP address, Prioritizing the wifi in service order.
5
  • Have you tried these steps Dinesh? They may help: osxdaily.com/2014/04/24/fix-mac-disconnect-wifi-sleep Aug 16, 2016 at 8:08
  • @Ian yes, I have tried it. It doesn't seems to work. Aug 16, 2016 at 8:21
  • Have you investigated what the command line tool airport can do for you? It has a few more options than those that are available in the GUI: itdojo.com/osx-airport-cli-tool-not-just-for-airport-aps I've had good results occasionally with the tool. Aug 17, 2016 at 7:03
  • 1
    I've been having the same problem since a few years with my mid 2014 macbook, now running Sierra. I tried every solution I could find, and although it seems fixed sometimes, the problem always comes back. I recently did a clean (not TM restore) install of my macbook as a last resort, and it didn't help -_- Mar 20, 2017 at 13:18
  • I still have this annoying issue with "MacBook Pro (Retina, 15-inch, Mid 2014" that runs "maxOS high sierra 10.13.4". any solutions ?
    – bicepjai
    Apr 15, 2018 at 20:29

2 Answers 2

2

I was having the same issue on one of my machines running both macOS Catalina and Big Sur. Tried forgetting the network and joining again, doing an SMC reset, and a few other solutions with no luck.

I was finally able to find a fix for it today (also posted it here https://alihaghani.me/blog/fix-mac-not-having-internet-access-on-wake):

  1. Go to System Preference → Network
  2. Select 'Advanced...' in the bottom right corner
  3. Go to the TCP/IP tab
  4. Enter 'ConnecMac' in the DHCP Client ID field
  5. Select 'Renew DHCP Lease' above the field
  6. Press OK
  7. In the System Preferences → Network, select the Location dropdown
  8. Select 'Edit Locations...'
  9. Select the plus sign to add a new location
  10. Enter 'Home' as its name
1

You may try this , i had same issue. Your computer may be set to disconnect automatically If you have to redial your dial-up modem Internet connection after not using your Mac for a few moments, or reconnect your PPPoE connection, your Mac may be set to disconnect automatically when the connection is idle.

1.Choose Apple menu > System Preferences, then click Network.

2.Select your modem port (internal or external) or your PPPoE configuration in the list at the left, then click Advanced.

3.Click PPP, then make sure “Prompt every __ minutes to maintain connection” is not selected, or if it is selected, increase the number of minutes that the computer can remain idle before disconnecting.

3
  • I could see such a configuration in Network. Aug 16, 2016 at 7:22
  • Surely that's only if the mac is connected directly to the ISP equipment and bypassing the router entirely? As I understand it, Dinesh is having trouble with his wifi not reconnecting after his mac wakes...? Aug 16, 2016 at 8:01
  • It didn't work. Mar 2, 2021 at 2:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .