0

I've gotten a MBP with El Captain installed & latest MRD (Microsoft Remote Desktop) 8.0.33 - However when I try connecting to a Windows host with it's PC name given along with credentials .. MRD gives me the following:

HTTPEndpointException: 4, The non-proxy http connection failed to connect with the message: 501 Not Implemented stack exchange

The same credentials & settings worked before, it somehow doesn't work now. I have done intensive research on it including this, this, this, this & this to no avail at all. I've also attempted to install Royal TSX, and it gives me the below:

The connection failed. (Error Code: CONNECTERROR)

I'm fed up & would require to handle office docs & mailboxes from my Windows Host. I can't ssh into for obvious office reasons. Can the community resolve this one?

  • tbh, trying to follow Windows around a truly dynamic DHCP setup using host name I gave up long ago as a hopeless task, even with a forced always-on Master Browser. In the end I just fixed all the relevant IP addresses in my DHCP server to static mappings & use those instead. – Tetsujin Aug 16 '16 at 13:17
  • @Tetsujin the GW needs to be assigned. Once if you are in a wireless network, the same config worked just as fine for me & now it just doesn't. I have a static IP with IP's assigned by DHCP to 2 different Win hosts. – Shritam Bhowmick Aug 16 '16 at 17:35
  • I think this might be up for a bounty since it's of a hack to be accomplished. Tried several times today without results. – Shritam Bhowmick Aug 17 '16 at 1:44
1

After a lot of trial & error, I figured out the most logical assumptions & got it to work. It goes like this (in-case anyone else finds the same problem & is looking forward to an answer):

  1. Determine the host gate way
  2. Physically access the computer
  3. Open up Windows Services (if host is Windows)
  4. In Services, look for Remote Desktop Services
  5. In Remote Desktop Services, click Properties & drop down to Automatic if not already
  6. Restart the Machine (Optional)

Try again with your MBP, and with Wireless connection, you need not set any additional GW info on RDP Client. Food for thought is - this could be one possible way out of many other circumstances you run into. Make sure RDP services aren't disabled on the GW which's suppose to distribute the connection packets & route it the way it should.

Let me know in case I could additionally help with something entirely different if the circumstances are different & RDP services are already not disabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .