0

I turned off the firewall. Then, using nmap in the terminal, I issued the statement

nmap 127.0.0.1

and got

Starting Nmap 7.12 ( https://nmap.org ) at 2016-08-15 11:00 PHT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00016s latency).
Not shown: 968 closed ports, 27 filtered ports
PORT     STATE SERVICE
22/tcp   open  ssh
80/tcp   open  http
631/tcp  open  ipp
3306/tcp open  mysql
9000/tcp open  cslistener

How can I force open TCP 443 on my machine?

  • 1
    What process or program do you want to listen on port 443? (or how did you get port 80 open assuming you want a web server to listen on both?) – bmike Aug 15 '16 at 3:45
2

To force open any port you can use nc (netcat).

The command sudo nc -l 443 will open port 443. Of course this will not serve any web pages. But it will be listed in your namp output as open port.

By specifying an interface with -b <if> you can bind it exclusively to it - other interfaces (e.g. en1) shouldn't show an open port 443 then:

sudo nc -b en0 -l 443

Check for more options by executing man nc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .