0

I have a folder/package in the Applications called CrashPlan.app. The uninstall failed and I am left with a folder that has a Contents folder, but aside from that, is completely empty.

The folder info:

drwxrwxr-x@ 3 root 102 13 Jul 20:36 CrashPlan.app

I have tried the following:

sudo rm -rf CrashPlah.app chown chflags nouchg

I tried the same things in Safe Mode and Recovery Mode. I tried disabling System Integrity Protection. Whenever I try to remove the folder I get: rm: CrashPlan.app/Contents: Operation not permitted rm: CrashPlan.app: Operation not permitted

Does anyone have any advise? I feel like I've tried everything.

  • Crash plan has an uninstaller on the dmg you download use that – user151019 Aug 14 '16 at 21:14
1

I jumped a gun posting here and got the answer elsewhere. Here is the solution: Because uninstall has already failed, the problem may be that the "system immutable flag" is set for /Applications/CrashPlan.app or its contents. In Terminal, try

ls -ldO /Applications/CrashPlan.app 

and

ls -ldO /Applications/CrashPlan.app/Contents

The ls command may show something like this:

drwxrwxr-x@  3 root  102  schg   13 Jul 14 20:36 CrashPlan.app

If you see the schg flag, run these commands:

sudo chflags -R noschg /Applications/CrashPlan.app
sudo rm -fR /Applications/CrashPlan.app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .