1

My early 2011 Macbook Pro which uses 10.6 Snow Leopard is going straight to OS X Utilities upon startup, no matter whether I use any startup keys or what those startup keys are. I have tried safe mode, resetting PRAM and SMC, recovery mode, everything I know of. Upon pressing the power button, the computer immediately turns on and chimes like normal, then goes to the white screen with the apple and a progress bar. After 5-10 minutes, it asks me to select a language, and then proceeds to OS X Utilities. I tried repairing the hard drive in Disk Utility with first aid, but it says it can't complete the repair. I tried erasing the hard drive (I have a recent backup), but it always tells me "Erase process failed." I tried restoring from Time Machine Backup, and although it found my backups on an external hard drive, it doesn't seem to recognize them.

Now here is what seems to have triggered the issue: I had just downloaded OS X Capitan and was attempting to install it, but the installation failed after the part where the computer restarts. When I go to Disk Utility I see Capitan there, but as with my hard drive, I can't erase it and neither can I eject it. When I go to "Reinstall OS X" it launches right into the Capitan installation, not the OS X 10.6 installation CD which is in the drive. Soon into the installation process, after it asks to verify my information with apple, a message pops up: "An error occurred while preparing the installation. Try running this application again." That's as far as I can get, and to clarify, I haven't been able to get beyond OS X Utilities at all.

I have another fresh hard drive that I could swap, but when I did swap it and then turned the computer on, it just goes to the apple and the spinning circle and stays there forever.

Yesterday I also exchanged the RAM and the battery, but I put the old ones back in and it still behaves the same so I don't see how that could be the issue.

I'm nearing my wit's end as it seems I've tried the few options available at this point, and I would be grateful it anyone has any suggestions or hypotheses as to what's going on and how I could go about fixing it.

EDIT (in response to Daniel): I tried starting up from the DVD installer by holding C down -- it just goes to the apple, the spinning wheel, and after a while ends up on a blank white screen. I've left it going like this for several hours so I'm pretty sure it's not just a matter of waiting. This is what it does every time, even when I startup pressing "option" and then choose the OS X install disk. Interestingly, when I startup with "option," my hard drive is labeled "OS X Install Disk," I guess because it is still in the process of trying to install Capitan.

When I put in my spare, clean hard drive, it actually does boot up from the install disk. However, when it comes time for me to choose where to install OS X, the computer recognizes the hard drive but says I can't install it there (no reason given).

Does all this suggest there is a problem with the hardware on the computer?

  • Please boot to (Internet) Recovery Mode, open in the menubar Utilities > Terminal, enter gpt -r show disk0 and diskutil cs list (each followed by hitting the Enter key), take a pic and add it to your question. – klanomath Aug 13 '16 at 3:46
  • OQ: "I have tried safe mode, resetting PRAM and SMC, recovery mode …". – dan Aug 13 '16 at 10:01
  • @danielAzuelos Do you want to address me with your comment? I'm not interested if the Recovery Mode works – it works and it's probably 10.11.3, because SL doesn't install one – but in the GUID/disk/CoreStorage structure. – klanomath Aug 13 '16 at 11:53
1

I tried repairing the hard drive in Disk Utility with first aid, but it says it can't complete the repair

Upon this kind of error, the first thing to understand is that you can't achieve anything of any value with your internal disk as long as it is in this unusable state.

This explains fully that your Mac is automatically trying a recovery.

Get (or make) a bootable USB key or DVD installer (they should be safe and obviously not built with your unsafe MacBook Pro).

Boot from it.

Start Utilities, Disk Utility and try to repair your internal disk from a safe version of Disk Utility.

If you succeed,

then install a clean version of the version of MacOS X you can install from an external safe medium (USB key or DVD installer),

else replace your internal disk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .