0

I am connecting my 2015 MacBook Air 13" to an external display via the Thunderbolt-to-VGA adapter. There are black bars on each side of the external display screen. How can I remove the bars?

  1. Macbook Air 13" (Early 2015)
  2. LG Flatron E2360
  3. Dell Thunderbolt to VGA Adapter.
  • On the sides of your display or computer? Try System Preferences > Displays, and uncheck 'mirror displays.' – ruddfawcett Aug 12 '16 at 15:51
  • on the sides of the external display. 'mirror displays' is already unchecked – user3655672 Aug 12 '16 at 16:16
1

I had this exact issue with a Thunderbolt to VGA adapter and an Acer display on my MBP. It was showing up as a projector, not a monitor, with black bars and low resolution. I simply plugged it into the other Thunderbolt and MBP recognized it as a 720p display.

Maybe also try updating OS X with adapter plugged in (this may force MBA to download a driver). Or downloading driver from manufacturer website. I would verify that the cables are properly connected too.

  • The trouble is MBA has only 1 Thunderbolt Port. :) – user3655672 Aug 12 '16 at 16:13
  • Have you rebooted, tried a PRAM reset – unknowndomain Aug 12 '16 at 17:21
  • did reset the PRAM, the issue still persists – user3655672 Aug 13 '16 at 3:45
1

The vertical black bars appear when the MacBook screen resolution and the external display screen resolution is not in the same ratio.

To fix that, when you connect to the screen, there is a prompt to choose which screen resolution you want to use. It’s either MacBook or the external display. This is how vanilla MacOS works.

Or, go Apple Menu --> System Preferences --> "Displays" pane set your preferred monitor resolutions there.

-1

Plug and play again helps. I don't know why but it helped for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .