0

My contacts are on my phone and I can choose them from the contact icon. I can not choose them to make a phone call or send a message. Incoming phone calls and messages do not display the contact name, I have tuned off contacts in iCloud and then back on but it did not fix the problem.

I did something in Facebook that was sending out friend requests to everybody. On trying to stop that I lost my contacts being attached to my phone calls and messages

  • Are there phones listed in your contacts? Where there phones at some point, and now there aren't? Do you remember any changes, installs updates that happened between those events? – Jaime Santa Cruz Aug 12 '16 at 6:05
1

Maybe you had Facebook contacts on and turned it off when trying to solve the other issue.

Check on Settings > Facebook to see if contacts are on.

facebook iOS settings

In order to be able to call and that incoming calls are identified your contacts need to have the phone listed. It also may need to be written in a specific format (+country code (area code) number, for instance).

0

Adapted from this thread on the Apple Discussion Forums.

DISCLAIMER: This may be outdated and may no longer work. As I have no way of testing this out, I decided to post it.

Reset the Contacts

  1. Navigate to Settings > Mail > Contacts > Calendars
  2. Turn on iCloud Contacts
  3. Go to your Address Book or Favorites
  4. Click on the Info Symbol to the right of one of your missing names.
  5. Scroll down and tap on Add to Existing Contacts, and then tap Cancel
  6. Then click on "Create New Contact", and then tap Cancel
  7. Exit Settings
0

I agree with @jaime Santa Cruz and the issue with Facebook integration screwed up my contacts from 200 to 1800 contacts and it was a pain made extra duplicates and numbers missing.

thank goodness in iOS 11 apple remote the social network like twitter Vimeo Facebook and more.

less fuss to worry about with those items removed.

Thanks

-1

I was facing same problem (no caller id) and solved it this way:

  1. Settings app
  2. General
  3. Reset
  4. Reset network settings
  5. If asked, enter the phone password
  6. Reset network settings

That's what fixed my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .