Every time I listen to music on iTunes or VLC, I notice that the process coreaudiod causes an unusually high CPU usage (5% or more).

Are you having the same issue? What's the reason for such a high CPU usage?

  • Recent OS X updates have not changed this observation. Restarting (or killing the process so it respawns) doesn't fix the problem. After a couple of seconds, CPU usage of coreaudiod goes above 5% again.

  • It's important to note that using line out makes the problem go away and coreaudiod's CPU usage goes down to 1%-2%.

enter image description here

  • 2
    yeah, i read those, none of the fixes fixed the issue... – Haytham Elkhoja Sep 13 '11 at 16:19
  • 1
    Yes, how weird is that? – Haytham Elkhoja Sep 15 '11 at 5:49
  • 2
    I'm having the same issue. Mac OS X 10.7.2; coreaudiod is using 8% CPU constantly. Issue goes away when I plug in the headphones. 2.4GHz Core 2 Duo MBP. I've read somewhere that Parallels could be under suspicion - anybody here using Parallels? – Scott Oct 30 '11 at 18:46
  • 1
    I experience the same too when I play through the speakers, I'll try the headphones. Thanks for sharing the tip, Haytham. – Global nomad Nov 20 '11 at 9:13
  • 1
    This problem still persists in 10.7.3. When listening to the radio, the coreaudiod is up at 10%! – gentmatt Feb 18 '12 at 9:00

12 Answers 12


The high CPU usage of coreaudiod is due to the ambient noise reduction software working (surprisingly, even when the built-in microphone is not in use).

Go to System Preferences > Sound > Input and uncheck the Use ambient noise reduction box.

Then, either reboot or run this one-liner to reload coreaudiod, and you should see coreaudiod CPU usage drop to 1% or less.

  • Dropped from 11% to 8% while audio is muted and nothing is playing. (2015 MBP 13") – Zenexer Aug 26 '15 at 22:41
  • 1
    After changing the setting, I also had to run "sudo killall coreaudiod" to actually get the CPU utilization to drop. I imagine rebooting would have accomplished the same thing as well. – DrFriedParts Jun 19 '16 at 23:56
  • 2
    Note that running sudo killall coreaudiod will make it so that you have no sound at all until you either reboot or properly reload coreaudiod. This one-liner should do the trick if you don't want to reboot. – Dave Yarwood Jan 22 '17 at 18:47

Certain applications appear to be triggering this problem when interacting with the microphone. The problem goes away a minute or two after the problem applications are closed.

Problem applications

These applications need to be restarted in order to restore normal CPU usage. They do not release their hold on the microphone properly.

  • HipChat after first time camera/mic are used, such as when opening preferences (see HipChat forums)
  • Boom by Global Delight Technologies (reference)--as far as I can tell, this shouldn't be using the microphone

Background applications

These applications could be running in the background while using your microphone.

  • Any VoIP application such as Skype or FaceTime
  • Adobe Flash in a web browser
  • Virtualization software such as VMware, VirtualBox, or Parallels. These will likely "listen" to your microphone whenever you have a virtual machine running, even if that virtual machine doesn't seem to be using the microphone at the moment. Most virtualization software allows you to disable audio hardware virtualization, which should solve this, although some may not be granular enough to disable the microphone without also disabling the speakers.
  • Specialized audio software such as that developed by Akai Pro (example report for EIE Pro with Logic X)
  • Voice search/recognition software, including Google Chrome's "Ok Google" voice search capability (reported as partially fixed by Chrome developers: Chrome will stop listening when switching users)
  • 1
    I also uninstalled Loopback's ACM or whatever its helper utility is, which kicked a restart of coreaudiod, and that brought it's CPU usage down to 0.0 (was 5.0-8.0 constantly). If you're not actively using Loopback, it seems like a good idea to uninstall its helper. – geerlingguy May 12 '20 at 14:39
  • 1
    This helped me: my application was Cisco Webex Teams, and the secret setting is in "Devices > Discover Devices > Use Ultrasound". Why this is on by default is beyond me – Colin Bradley May 27 '20 at 8:05
  • In my case it was the telegram app – randomcontrol Jul 10 '20 at 20:43

This appears to be a know issue, and hopefully will be fixed in an update in the future. For now though, there are one or two things you could try (it goes without saying that make sure all software is updated to its highest stable version)

  • First of all, restart your computer.
  • Second of all, install Onyx. Install and open, and click on the 'Cleaning' tab. Under that, make sure, on the 'System' section, that the 'Audio Components' option is checked. Click execute, and let it do it's thing.
  • Then open Disk Utility, select your startup volume, and repair all disk permissions. Let it run, then close all apps and restart again.

I hope this helps relieve the problem in some way, but I cannot guarantee it, having not been afflicted with it myself, however this is the course of action I take whenever my CPU usage is higher than I would expect it to be due to a process.

  • 9
    This is not a solution in any way, shape or form. – Haytham Elkhoja Dec 28 '11 at 11:24
  • 2
    CPU went from 8 to 120 % and was constantly fluctuating. Deleting Library/Preferences/Audio did not work for me but the instructions from All Maxwell did the trick. – Yves_T Apr 11 '13 at 16:51

A tab in google chrome running WhatsApp keeps the system awake; in particular, coreaudiod is running. See https://webdiary.com/tag/coreaudiod/

  • Welcome to Ask Different! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post once you have sufficient reputation. If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Tetsujin Apr 16 '16 at 8:48
  • This was indeed wat was causing coreaudiod to eat up 8% cpu continuously on my mac. After closing the tab, the cpu usage immediately disappeared. – Friek May 19 '16 at 20:53

Seems like creating the folder Library/Preferences/Audio worked for at least some people. Have you tried it?

  • The user just copied /Library/Preferences/Audio/ from another computer. I also had the issue on my previous Mac though. If it worked for someone, can you upload the plist files somewhere? – Lri Dec 31 '12 at 10:18

This is indeed due to Google Chrome browser continuously using the microphone to listen for the hotword 'OK Google'. While unchecking noise reduction in the system audio preferences will decrease CPU usage (in my case from 12% to 8% coreaudiod) this does not fix the underlying issue.

To completely resolve the issue open Google Chrome -> Settings -> Search -> and disable 'Enable "OK Google" to start a voice search'.

My coreaudiod CPU usage went from 12% to zero.


This could be audio plugins that run under core audio.

  • While this seems reasonable at first, it does not explain why "plugging in earphones or external speakers makes the problem go away". – gentmatt Jan 24 '13 at 12:37

I just had the same issue on 10.8.4.

Quitting Boom.app seems to have resolved it for me.

I think Boom uses similar technology as AirFoil, so it might be worth quitting or uninstalling anything that somehow captures and modifies or redirects the audio-stream.

Perhaps the app afflicting you saves state per output device, and it's state for your built-in speakers is borked somehow.

  • The poster did not indicate that he's using any third-party plugins or applications, other than VLC. – tubedogg Sep 3 '13 at 21:13
  • I tried muting BoomDevice (under System Preferences->Sound) in both the Output and Input device lists, and my CPU usage for coreaudiod immediately dropped. – Sean the Bean Mar 19 '14 at 19:49
  • Interestingly, I uninstalled Boom a long time ago, but BoomDevice is still installed.. I'll have to fix that. – Sean the Bean Mar 19 '14 at 19:50

Disabling "Google Voice Search Hotword (Beta)" extension in Google Chrome helped... OS X 10.9.1 Mavericks


Here in 2020, I had a couple of clones of iOS Simulator running an (otherwise idle) app. coreaudio was taking about 18% CPU, and quitting the Simulator dropped it to zero.


I found that killing Flash fixed the problem for me.

I rebooted yesterday to see if that would fix the problem, but by this afternoon, coreaudiod had accumulated 6 hours of CPU time. I have not used any audio apps (VLC, iTunes, etc.).

I turned off "ambient noise reduction" and there was no impact - still at 8-10% CPU. I noticed Flash running with a much lower CPU (~1%), but I did not realize that I was visiting any Flash-based websites. I killed Flash, and coreaudiod disappeared from Activity Monitor. When I re-enabled "ambient noise reduction" there was no impact - coreaudiod still gone. (This all on OS X 10.9.)


Some people claim this helps:

$ sudo launchctl unload /system/library/launchdaemons/com.apple.audio.coreaudiod.plist
$ sudo rm -r /Library/Preferences/Audio/
$ sudo mkdir /Library/Preferences/Audio
$ sudo chown -R _coreaudiod:admin /Library/Preferences/Audio
$ sudo launchctl load /system/library/launchdaemons/com.apple.audio.coreaudiod.plist

For me it turned out the cause was this HipChat issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .