1

I have an Apple MacBook Pro Early 2015, with AirPort issues.

The problem is extremely complex, but effectively it means I get page time out intermittently.

  • I've reinstalled macOS from scratch, without backup, twice.
  • The issue only happens on Wi-Fi.
  • It happens when on WPA Personal Wi-Fi, but not Enterprise, unsure about Unsecured and WEP.
  • It happens on 2.4Ghz and 5Ghz on any wireless channel, regardless of interference.
  • I can still ping local devices, but HTTP requests to the router's config page for example do not work, and internet requests either.
  • It isn't DNS related as I've tried 3 DNSs and tested with IP addresses
  • There is no Firewall, or tools like LittleSnitch running
  • I can see when the issue occours by pinging 8.8.8.8
  • Other devices on the same internet connection both wired and wireless are unaffected.
  • The issue is resolved by a reboot.
  • I've reproduced this at other locations, as well as trying a new Router from my ISP, Virgin Media, and buying a Ubiquiti UniFi AP-AC-LR
  • We've run Wireless Diagnostics, which Apple Engineering has looked at and not found anything.
  • They have changed the AirPort card
  • Tried PRAM and SMC resets, and most the stuff on this thread: Wifi Keeps Dropping Macbook Pro 13in Retina Early 2015

I'm completely out of ideas, Apple are refusing to replace the Mac, and my work colleague has the identical issue on a newer but same model of MacBook Pro.

Does anyone have any idea how to proceed, I have been waiting for Apple to deal with this and they seem to have no idea, what the issue is.

  • Try to look at the traffic with wireshark. – Ortomala Lokni Jan 4 '17 at 18:42
  • Updating to the latest major OS earlier this month was the solution. – unknowndomain Jan 4 '17 at 22:01
0

Resolved by upgrading to macOS Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .