0

On iPhone 4, there is no name of the sender of SMS nor iMessage, only his/her number, and naturally, I want the name to be displayed too. How to do this? I tried some things like:

  1. Resetting the phone using sleep button
  2. Resetting the phone using sleep+home at the same time
  3. Toggling on/off iMessages in Settings -> iMessages,
  4. Setting short name/last/first name,
  5. Toggling contacts in Settings -> iCloud,
  6. Toggling iCloud itself even (delete iCloud account on the iPhone and re-add it),
  7. Resetting Network settings
  8. I also tried setting the default account from iCloud to Gmail, and deleting the contact, and adding it again, this time to Gmail account (being the default one, this is what happens).

Still doesn't work, only the number is displayed, and appears it is not synced to contacts at all. How can I have the name of the sender (from contacts) displayed in the SMS so I know from whom the SMS or iMessage is from?

To be more specific, this is not the problem with short names, but the names are not displayed at all, only the person's number. Obviously, I don't remember people's phone numbers, so I really need this to work.

  • 1
    Can you search for the phone number in Contacts? – haykam Aug 8 '16 at 23:12
  • Yes, the phone number is in my contacts. And I can't see it in messages. Please read my question once more for all the details. Nothing worked so far :) I also tried setting the default account from iCloud to Gmail, and deleting the contact, and adding it again, this time to Gmail account (being the default one, this is what happens). Still doesn't work. – Vladimir Despotovic Aug 8 '16 at 23:13
  • 1
    This answer might help you. – haykam Aug 8 '16 at 23:13
  • 1
    Is the number in the same format on the SMS and on your contact? In my country some SMS messages have a truncated version of the number (missing the country and area code for instance) and that will make them not to be associated to the contact. – Jaime Santa Cruz Aug 9 '16 at 11:41
  • 1
    @VladimirDespotovic another crazy thing that worked for me: some carriers truncate the sender number, and I had to add the truncated version to get it associated to the contact when receiving SMSs... It seems as it is not the case in your situation though, but it may help others. – Jaime Santa Cruz Aug 12 '16 at 13:47
2

I just had this issue happen on iOS 10.0.2. It started after I signed out of iCloud and back in (all of my contacts are stored on iCloud). I tried some of the same things you tried, all to no avail.

In my case, I noticed that all of the old message threads showed "+1 (nnn) nnn-nnnn", but all of my contacts use the "(nnn) nnn-nnnn", i.e. no country prefix. On a whim, I edited just one of the contacts that was having the issue and added the +1 prefix to their mobile number. I switched back to Messages, and right away, not only was that message thread fixed, they all were! Then I went back to that contact, removed the +1, and everything was still fixed. An easy fix, but very odd!

Of course, if you're outside the US you may need to use a different country prefix.

1

I had the same problem as the OP, and the above answer from sclamage gave me the hint I needed: I had gone into my iPhone 6s (iOS 10.3.1) and turned off: Settings->{My Name}->iCloud->Contacts. In hindsight, of course that broke everything. Slowly, my numbers are turning back into names and photos from my contacts. Thank you sclamage! I hope this helps anyone else with this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .