When using Spotlight on my Mac, and I type Spo... (trying to launch Spotify), I get suggestions for the Spotify website, some apps from the App Store, and files containing a fraction of the word "spo" but no Spotify.app.

When trying to search for other apps using Spotlight, if the app shows up, the focus is not on the app, it is on a web search for the app name. This is really frustrating, as i type quickly and Spotlight launches Safari instead of the app I'm searching for.

I need to mention that I did a fresh install of OS X for 2-3 weeks (didn't restore my stuff from time machine backup. I did it the old fashioned way (copy/paste to external HDD, then back to Mac), but after my install Apple released an OS X update.

Please bring some light on this situation.

  • 1
    Within System Preferences, in the Spotlight Search section, is it set not to search for Apps? Can't remember if it's inside of Privacy & Security or inside Spotlight. -- hope this helps. – bret7600 Aug 8 '16 at 0:05
  • This is not a duplicate; this is specifically about Spotify. There are reports all over the web that this app, specifically, has trouble staying in the finder index. I never have any trouble with any other app, but Spotify keeps disappearing. Not a dupe of the generic "no apps in spotlight search, at all". – hraban Jun 9 '19 at 0:45

Anil (https://apple.stackexchange.com/users/40587/anil) answered in this question (Applications Don't Show Up in Spotlight). It worked for me on Sierra.

Here is his solution:

Turn off spotlight:

sudo mdutil -a -i off

Unload it:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Load It:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Turn on spotlight again:

sudo mdutil -a -i on
  • Welcome to Ask Different. Rather than answer the question again, it should be flagged as a duplicate. But thank you for pointing it out so it can be flagged. – Allan Jan 16 '17 at 2:17
  • 4
    I got an error when trying to unload the plist (Operation not permitted while System Integrity Protection is engaged) but just turning off spotlight and turning it back on triggered a reindex which solved the problem. – Warkst Aug 30 '17 at 10:05
  • For me, it was enough just to turn it off and on. – Aleksey Potapkin Dec 1 '17 at 13:24
  • I got similar errors as well however just keep following the steps. Despite the errors the result is there – Rutger Huijsmans Apr 18 '18 at 15:30

Not the answer you're looking for? Browse other questions tagged .