3

Please refer to the image to see how Storage is showing me the space division.

enter image description here

Its showing amount of space available correctly but the division below is incorrect as you can see it is showing 249.72 GB for Apps and I only have 249.78 GB total space.

What can I do to correct this?

Edit :

Hi guys, thanks to everyone who responded and provided there inputs to solve my problem, really appreciate it. I don't know how but the space division is showing correct division now (I guess) , here is the snapshot of what is currently displayed :

enter image description here

I am not sure how it got corrected, the only thing I did was restart and immediately there was no change, but then I had some work and came back to the macbook again and saw the above scenario. Still not sure what does other signify and I am pretty sure that the space allocated to apps is wrong, is there anywhere I can check other than storage about how much space is allocated to Apps?

  • Possible duplicate of Storage only shows "Other" + Fluctuating storage – mmmmmm Aug 7 '16 at 15:43
  • @Mark I see this as different. In the other case, the numbers added up, but the characterization of file type was wrong. Here, the failure is more pervasive and severe. The color bar should be half empty here (140/250 fraction empty) and the numbers for Apps is clearly wrong. My guess is that the hardware / drive is failing or there's something odd about the setup. Maybe a VM / hackintosh? – bmike Aug 7 '16 at 16:44
  • @bmike It is not a VM/hackintosh, and I am able to use the spotlight functions without any issues. The issue was just at the storage not displaying division of space correctly. Now I have updated the question with the current situation where I can see the divisions correctly but there is an other section which I don't know points to which files. – Ankit Jain Aug 7 '16 at 18:44
2

I had a similar problem, and rebuilding my Spotlight index solved it for me.

Simply restarting my computer (a less time costly operation), has also worked in the past.

| improve this answer | |
  • 1
    restarted my system but the problem is still there, will be rebuilding my Spotlight index and will share if that resolves the issue. – Ankit Jain Aug 7 '16 at 15:50
  • 2
    @AnkitJain Usually whatever corruption exists on the filesystem that tripped up the spotlight build in the first place is there and you'll need to find that file. It's a good thing to try, but I've found that "rebuilding spotlight" is a bit like "repairing permissions" in that it's overly broad, applied as something you can try and not really attacking the root cause of things. – bmike Aug 7 '16 at 16:21
  • @bmike valid comparison. Wondering if there's a way to target specific file... – ruddfawcett Aug 7 '16 at 17:13
  • I grab a mddiagnose before I rebuild spotlight - look for importer errors in system.log and then grab another mddiagnose after the rebuild. I look at the diagnostic.log from the bottom up to see if there are any oddball error counts and get a sense of what crashes / busy times are for spotlight. It's really quite complicated for causal "good/bad" diagnosis. – bmike Aug 7 '16 at 17:21
1

The spotlight database and indexing process does generate the data, so if you are able to use Activity Monitor to look at all processes (or top -u -s 10 at the unix command prompt) you might let spotlight finish indexing and see if this is a temporary situation due to poor estimates of the files on the disk.

If this is something that persists more than 48 hours (set the OS to not go to sleep), I would capture spotlight diagnostics in terminal by running mddiagnose and then make a full backup and contact Apple Support.

If you don't have support, the next step would be to erase the drive and reinstall the OS. After a clean install, spotlight should index over an hour or three and the settings should be 100% correct.

At that point, you know the OS works, the hardware works. Then you can restore files and apps from the backup.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .