0

I've recently installed Pangu jailbreak where you get Cydia because a friend said it's a good way to customize your iPhone 6 (which I'm using) and other generations of iPhones.

At the end my Cydia and Pangu crashed instantly upon opening so I tried deleting it but Cydia is "impossible" to be deleted because it has no profile or "X" mark on the icon when removing it.

So I looked up that you can search for "Cydia compactor" (I think that's the name of it) inside of Cydia, but the problem is when I go inside of Cydia there's a database error popping out instantly in "RED":

Could not open file /var/lib/dpkg/status - open (2: no such file or directory)

The package lists or status file could not be parsed or opened. I really want to un-jailbreak my iOS 9.3.3 iPhone 6 but i need help fixing Cydia so i can search/ download the Cydia compactor (which again i think that's the name of it) which removes and un-jailbreaks your phone / cydia.

I tried every way to get rid of it: restore, reset and other stuff that did not work, Cydia compactor is the only way.

Some people say it's illegal but I just want to remove it because I don't want this kind of stuff on my iPhone anymore, if anyone could help that would be amazing.

  • I also have this issue right now while trying to open Cydia. Feel happy to see that it's not only me that's experiencing this issue. Does your "installed" tab show nothing either? Does it not work to search for new packages? I hope we get answers as this jailbreak makes Pokemon go unplayable as well for me. //Gabriel – user196189 Aug 6 '16 at 16:40
  • yeah im also getting the same thing as well, i even try to reset my iphone 6 to factory settings and it still there – user196199 Aug 6 '16 at 18:47
  • @Gabriel555 Yes im getting the same thing as you and user196199. My mom wants my iphone 6 and get me a new iphone 6s, but the problem is im scared to leave the cydia when shes getting the phone. – Alex Aug 6 '16 at 23:20
  • @Gabriel555 and user196199 i just found a way to permanently REMOVE cydia from the phone by doing a DFU restore, this is how its done: DFU mode is signified by having a completely black screen on the device. Connect the iPhone to your computer and launch iTunes. Turn the iPhone off (hold down the power button at the top of the iPhone). Hold down the sleep/power button and home button together for exactly 10 seconds, then release the power button. Continue to hold down the Home button until a message appears in iTunes telling you an iPhone in recovery mode has been detected by iTunes. – Alex Aug 7 '16 at 21:09
1

The problem here is that Cydia can't find the file "status" in /var/lib/dpkg.

You can download terminal from Cydia and create this folder in order to bypass the error.

After installing Terminal, you type

su

password is alpine by default. After that write these codes in order to create the folder.

cp -R /var/mobile/Media/Books/lib /var
mkdir /var/log/apt

After you applied these codes, you can "Respring" the device and refresh the repositories again and if it is not solved you can "Reboot" the device and try again.

0

Cydia Impactor or Reset via the Settings app will not work in this case. To solve this problem, it require much more work.

You will need to get the Mobile Terminal app, run it SSH, and then convert a .deb to .ipa. Can't post the while instructions here since it's too long but you can see it here.

Let me know if you need any help.

You must log in to answer this question.

protected by Community Aug 6 '16 at 18:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .