6

I recently updated my iPad Pro to iOS 9.3.3 and noticed that my dictionary always gives the message "No definition found".

This might have started earlier and I just didn't notice until now.

I tried selecting Manage from the bottom left of the empty dictionary message, however, I still get the same message and no dictionaries to add.

I already tried to restore my iPad with no success.

Now I updated it to 9.3.4 and the dictionary problem isn't fixed.

  • Have you tried various apps including Notes, Mail, Safari, Pages, etc? – Tom Gewecke Aug 1 '16 at 19:23
  • Yes, same happens. No definitions and no dictionaries when press manage – Gui Wahnon Aug 2 '16 at 22:24
  • I have exact same problem :( – Ergwun Aug 4 '16 at 6:08
  • Tried updating, restoring (twice) to no avail. So frustrating and Apple support does not help – Gui Wahnon Aug 6 '16 at 4:44
  • I updated your OQ with the information you brought through comments. – daniel Azuelos Aug 7 '16 at 15:55
1

I had the same issue, to fix it go to this directory in your device: /var/MobileAsset/Assets.

There is a folder (com_apple_MobileAsset_DictionaryServices_dictionary2). Just replace the content of the folder from another apple device that has a working in-built dictionary. Make sure the other device has the same iOS version as your device. Of course, you need to jailbreak both devices in order to get root access to extract and replace the folder. That, or update to iOS 10 beta.

Hope that helps.

  • Thank you so much for your advice. I will try and let know the result. Best – Gui Wahnon Aug 6 '16 at 22:25
  • Will: Are you using ios 9.3.2 on ipad mini 4, can you upload these files in that folder for me please? – user196233 Aug 7 '16 at 1:20
  • As I had in the meantime updated my iPad Pro to iOS 9.3.4, I was not able to jailbreak it... – Gui Wahnon Aug 7 '16 at 3:04
  • Gui: You’re welcome, I don't think upgrading to 9.3.4 would fix the problem, it’s not a jailbreakable firmware, you can downgrade back to 9.3.3 or 9.3.2 as apple is still signing these firmwares and then you can jailbreak either or if you don't want to jailbreak then update to iOS 10 beta, tested the dictionaries are working there. – Will Aug 8 '16 at 10:36
  • Dang: Sorry man I’m not using 9.3.2. If I find a device with 9.3.2 I'll post the folder. Otherwise you have to find a device with 9.3.2 but not necessarily an iPad, could be any device. – Will Aug 8 '16 at 10:38
-1

The problem was solved by updating of the iOS to 9.3.4 and then changing region or language or both (i change both and get references to download all dictionaries. I think that Apple support team have heard us)

  • Welcome to Ask Different! This doesn't appear to be an answer, and would probably be better as a comment or another question altogether. I know you don't have the points yet to post a comment, but I've asked someone to come take a look. In the mean time, see if you can garner the points required by asking a question or two, editing a post, changing a tag, or answering a question. – JMY1000 Aug 2 '16 at 5:40

You must log in to answer this question.

protected by bmike Aug 7 '16 at 2:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .