1

I have a 5K iMac, late 2015, running El Capitan.

Two days ago, I enabled FileFault. After that, when I wake up, I find that the machine has rebooted to the login screen, showing me icons for all available users. At the bottom is a message about what to do if I'm unable to type my password. It happened last night, and the night before that, which is the first night after FileVault was enabled.

I have "log out after X minutes of inactivity" deselected.

I suspect it was a power failure, but I have a UPS, and "Start up automatically after a power failure" is deselected, so that can't be the reason.

These are the log entries from the middle of the night:

1 Aug 16 1:07:05.682 AM com.apple.cts[234]: com.apple.EscrowSecurityAlert.daily: scheduler_evaluate_activity told me to run this job; however, but the start time isn't for 75112 seconds.  Ignoring.
1 Aug 16 1:07:05.682 AM com.apple.cts[45]: com.apple.SoftwareUpdate.Activity: scheduler_evaluate_activity told me to run this job; however, but the start time isn't for 9859 seconds.  Ignoring.
1 Aug 16 1:07:05.000 AM kernel[0]: ARPT: 29370.909170: wl0: TCPKEEP: locate_keepalive_data_new_uc: No IPV4 addrs, keepalive not started.
1 Aug 16 1:07:05.000 AM kernel[0]: ARPT: 29370.909178: wl0: MDNS: IPV4 Addr: 192.168.0.215
1 Aug 16 1:07:05.000 AM kernel[0]: ARPT: 29370.909181: wl0: MDNS: IPV6 Addr: fe80:0:0:0:2af0:76ff:fe3f:9670
1 Aug 16 1:07:05.000 AM kernel[0]: ARPT: 29370.909184: wl0: MDNS: 0 SRV Recs, 0 TXT Recs
1 Aug 16 1:07:07.000 AM kernel[0]: PM response took 1994 ms (54, powerd)
1 Aug 16 1:07:07.000 AM kernel[0]: ARPT: 29372.905516: AirPort_Brcm43xx::powerChange: System Sleep 
1 Aug 16 1:07:08.000 AM kernel[0]: ARPT: 29373.407643: IOPMPowerSource Information: onSleep,  SleepType: Normal Sleep,  
1 Aug 16 2:05:12.000 AM kernel[0]: AppleThunderboltNHIType2::prePCIWake - power up complete - took 44 us
1 Aug 16 2:05:12.000 AM kernel[0]: Bluetooth -- LE is supported - Disable LE meta event
1 Aug 16 2:05:12.000 AM kernel[0]: AppleThunderboltGenericHAL::earlyWake - complete - took 0 milliseconds
1 Aug 16 2:05:12.000 AM kernel[0]: AirPort: Link Down on awdl0. Reason 1 (Unspecified).
1 Aug 16 2:05:12.000 AM kernel[0]: ARPT: 29375.199822: wl0: leaveModulePoweredForOffloads: Wi-Fi will stay on.
1 Aug 16 2:05:12.000 AM kernel[0]: ARPT: 29375.220725: AirPort_Brcm43xx::platformWoWEnable: WWEN[enable]
1 Aug 16 2:05:12.000 AM kernel[0]: ARPT: 29375.221700: AirPort_Brcm43xx::syncPowerState: WWEN[enabled]
1 Aug 16 2:05:12.000 AM kernel[0]: IOThunderboltSwitch<0>(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 11 unplug = 0
1 Aug 16 1:07:10.000 AM kernel[0]: AppleThunderboltNHIType2::waitForOk2Go2Sx - intel_rp = 1 dlla_reporting_supported = 1
1 Aug 16 2:05:12.000 AM kernel[0]: AppleThunderboltNHIType2::waitForOk2Go2Sx - retries = 4292
1 Aug 16 2:05:12.000 AM kernel[0]: Wake reason: EC.SleepTimer XHC1 (SleepTimer)
1 Aug 16 2:05:12.000 AM kernel[0]: Previous sleep cause: 5
1 Aug 16 2:05:12.000 AM syslogd[44]: ASL Sender Statistics
1 Aug 16 2:05:12.000 AM kernel[0]: AppleThunderboltNHIType2::prePCIWake - power up complete - took 1 us
1 Aug 16 2:05:12.000 AM kernel[0]: AppleThunderboltGenericHAL::earlyWake - complete - took 1 milliseconds
1 Aug 16 2:05:12.000 AM kernel[0]: IOThunderboltSwitch<0>(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 11 unplug = 0
1 Aug 16 2:05:12.000 AM kernel[0]: IOThunderboltSwitch<0>(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 12 unplug = 0
1 Aug 16 2:05:12.000 AM kernel[0]: TBT W (2): 0x0040 [x]
1 Aug 16 2:05:12.000 AM kernel[0]: en1: BSSID changed to 58:6d:8f:3c:7a:b1
1 Aug 16 2:05:12.000 AM kernel[0]: en1: channel changed to 36
1 Aug 16 2:05:12.000 AM kernel[0]: in6_unlink_ifa: IPv6 address 0xcc7b8f4ef800638d has no prefix
1 Aug 16 2:05:12.360 AM com.apple.xpc.launchd[1]: (com.apple.AddressBook.SourceSync) Service only ran for 9 seconds. Pushing respawn out by 1 seconds.
1 Aug 16 2:05:12.530 AM Dock[305]: -[UABestAppSuggestionManager notifyBestAppChanged:type:options:bundleIdentifier:activityType:dynamicIdentifier:when:confidence:deviceName:deviceIdentifier:deviceType:] (null) UASuggestedActionType=0 (null)/(null) opts=(null) when=2016-07-31 20:35:12 +0000 confidence=1 from=(null)/(null) (UABestAppSuggestionManager.m #319)
1 Aug 16 2:05:13.752 AM ntpd[217]: wake time set +0.736000 s
1 Aug 16 2:05:13.824 AM hidd[97]: [HID] [MT] MTSimpleHIDManager::deviceDidBootload device bootloaded
1 Aug 16 2:05:14.000 AM kernel[0]: AirPort: Link Up on awdl0
1 Aug 16 2:05:16.000 AM kernel[0]: ARPT: 29379.679635: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
1 Aug 16 2:05:16.000 AM kernel[0]: ARPT: 29380.181526: IOPMPowerSource Information: onWake,  SleepType: Normal Sleep,  
1 Aug 16 2:05:16.000 AM kernel[0]: ARPT: 29380.181673: AirPort_Brcm43xx::platformWoWEnable: WWEN[disable]
1 Aug 16 2:05:17.000 AM kernel[0]: [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
1 Aug 16 2:05:24.576 AM AddressBookSourceSync[4341]: AOSKit WARN: (-) Invalid url: https://kartick.vad%40gmail.com@carddav.linkedin.com/v1/carddav/154962696/
1 Aug 16 2:05:54.690 AM AddressBookSourceSync[4346]: AOSKit WARN: (-) Invalid url: https://kartick.vad%40gmail.com@carddav.linkedin.com/v1/carddav/154962696/
1 Aug 16 2:05:57.000 AM kernel[0]: pci pause: SDXC
1 Aug 16 2:06:01.000 AM kernel[0]: ARPT: 29425.188215: wl0: TCPKEEP: locate_keepalive_data_new_uc: No IPV4 addrs, keepalive not started.
1 Aug 16 2:06:01.000 AM kernel[0]: ARPT: 29425.188222: wl0: MDNS: IPV4 Addr: 192.168.0.215
1 Aug 16 2:06:01.000 AM kernel[0]: ARPT: 29425.188226: wl0: MDNS: IPV6 Addr: fe80:0:0:0:2af0:76ff:fe3f:9670
1 Aug 16 2:06:01.000 AM kernel[0]: ARPT: 29425.188228: wl0: MDNS: 0 SRV Recs, 0 TXT Recs
1 Aug 16 2:06:03.000 AM kernel[0]: PM response took 1992 ms (54, powerd)
1 Aug 16 2:06:03.000 AM kernel[0]: ARPT: 29427.181838: AirPort_Brcm43xx::powerChange: System Sleep 
1 Aug 16 2:06:04.000 AM kernel[0]: ARPT: 29427.683945: IOPMPowerSource Information: onSleep,  SleepType: Standby,  
1 Aug 16 7:51:18.000 AM bootlog[0]: BOOT_TIME 1470018078 0

The last log entry is that of going to sleep. It rebooted in the middle of the night, but there are no log entries because of full disk encryption — I did not type my password in the middle of the night. I instead powered it off, and booted it at 7 AM when I woke up.

I checked pmset -g log:

2016-08-01 02:06:01 +0530                       Summary- [System: PrevIdle] Using AC                                                  
2016-08-01 02:06:01 +0530 Sleep                 Entering Sleep state due to 'Maintenance Sleep': Using AC           
2016-08-01 02:06:03 +0530 Wake Requests         [proc=mDNSResponder request=Maintenance inDelta=7198] [proc=UserEventAgent request=SleepService inDelta=48597 info="AppRefresh:com.apple.apsd.apprefresh,BGTask:com.apple.backupd-auto,"] [*proc=UserEventAgent request=TimerPlugin inDelta=3597 info="AppRefresh:com.apple.apsd.apprefresh,BGTask:com.apple.backupd-auto,"] [proc=UserEventAgent request=TimerPlugin inDelta=3597 info="BGTask:com.apple.Safari.SafeBrowsing.Update,"]           
2016-08-01 02:06:03 +0530 PM Client Acks        Delays to Sleep notifications: [com.apple.apsd is slow(1990 ms)]           
Sleep/Wakes since boot at 2016-07-31 07:35:23 +0530 :0   Dark Wake Count in this sleep cycle:3

Time stamp                Domain                Message                                                                     Duration    Delay     
==========                ======                =======                                                                     ========    =====     
UUID: (null)
2016-08-01 07:51:20 +0530 Start                 powerd process is started                                                             
2016-08-01 07:51:20 +0530                       Summary- [System: No Assertions] Using AC                                             
2016-08-01 07:51:21 +0530 Assertions            Kernel Idle sleep preventers: IODisplayWrangler          
Sleep/Wakes since boot at 2016-08-01 07:51:20 +0530 :0   Dark Wake Count in this sleep cycle:0

Time stamp                Domain                Message                                                                     Duration    Delay     
==========                ======                =======                                                                     ========    =====     
UUID: Unknown UUID

I reset the SMC, but what else do I do to fix this problem?

0

Disabling FileVault stopped the reboots. The Apple support person I spoke to theorised that the hard disc may not have been fully encrypted when I turned encryption on. In any case, decrypting it fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .