1

I am at a school where almost all the school computers are Windows 10.

Each student has a personal directory on a fileserver where most everything else is public.

I had my directory and one of the public directories mount on boot in my Mac (10.11.6) with /etc/auto_smb

I used the same syntax for both mounts. Both worked fine for a few days, but for two days now, the public directory is available completely, but LibreOffice and Finder cannot see my personal directory.

'ls -la' shows my Mac OS account (group wheel) as the owner of all files in both directories, which I am guessing means that whatever filesystem they are on does not have owners and groups. My Mac account is not in wheel.

'open (name)' in the shell works for the public directory. In the personal directory, it gets "LSOpenURLsWithRole() failed with error 5 for the file (name)" whether (name) is a subdirectory or a file.

UPDATE: (1) Everything works correctly in one building but is weird in another. The difference is the physical WiFi access point. Same SSID, same password, the two directories in the same disk on the same server.

(2) In the building where the weird behavior occurs, bash and TextEdit have no problem. LibreOffice, Adobe Reader, and Finder cannot see one of the two directories. Permissions don't change on the server when I go from one building to another. And if they did, how would some apps not have permission for the same user?

What has probably happened and how can it be fixed?

  • Same error if I try to open a PDF in the personal directory. – WGroleau Aug 1 '16 at 2:52
  • OK, this is just weird. It worked OK for a few days, had this "partial failure" for at least two days over at least two reboots, and now it's working again. SMH. – WGroleau Aug 1 '16 at 4:09
  • LSOpenURLsWithRole is usually an execute permission error. Check your perms are at least rwxr-xr-x – Tetsujin Aug 1 '16 at 6:31
  • It's not permissions. I'll add to the question a detail I inadvertently omitted and one I just discovered. – WGroleau Aug 2 '16 at 19:57

You must log in to answer this question.

Browse other questions tagged .