I hope this is the right place to ask this kind of problem. So, before the Lion, when I tried to ignore something on Apache Subversion (svn), I just typed the following command: svn propedit svn:ignore .
So this opened a temporary file for the current directory with the selected editor and I could write there my patterns, which where ignored by the svn.
After the I installed Lion, when I type this command the following error appears: The document “svn-prop.tmp” could not be opened. The file doesn’t exist.
Did anybody else met this error before? (I tried googling, but I didn't find any solution).

  • What editor is configured for the shell/SVN? – Gerry Sep 12 '11 at 12:54
  • It is the default, it is what I got with the system. I didn't configure any new. – Infinity Sep 12 '11 at 13:04
  • Which editor does the command launch then? – Gerry Sep 12 '11 at 13:45
  • TextEdit, I've used this since I am using svn. – Infinity Sep 12 '11 at 21:29
  • That is definitely not the default and it surprises me it worked before. – Gerry Sep 13 '11 at 7:50

As Gerry pointed out calling TextEdit directly will not work but you can use open:

open -e -W -n

in your case

export SVN_EDITOR='open -e -W -n'
  • -e opens with TextEdit (you can use -a to specify another application)
  • -W waits that the application exits
  • -n opens a new instance (so that you will not have to quit an eventually open TextEdit)
  • Yes, this is the answer. Thanks to post it here too. :) – Infinity Sep 13 '11 at 19:30

The problem with GUI editors is that when launched from the command-line, they generally do not halt the process in the shell. That's why when editing a property, svn will create the temporary file, launch the editor, and wait for the exit signal to read and delete the temporary file contents. Because the GUI editor returns the exit signal immediately upon launching, the file will no longer be there.

Some GUI editors like TextMate and Sublime Text support a -w (wait) option from the command-line, forcing them to halt the SVN process until the file is closed. I am not aware of TextEdit supporting such an option.

You probably want to change your SVN editor to something more appropriate, like vim or nano. You can change the editor command in ~/.subversion/config

  • Yes, you are true, but I also found a solution to start TextEdit. I will post it soon. – Infinity Sep 13 '11 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .