1

I am using a MacBook Pro 13" retina early 2015, running macOS 10.12 Sierra public beta 2.

For the last two days my computer is not usable since there is no available RAM memory to use, the OS is just freezing and after few minutes the computer restarts itself.

I checked the activity monitor to see what is the cause of that problem and I noticed that the kernel_task, the mds_stores, the mdworker and the mdworker32 tasks are using all of my RAM memory. Activity Monitor when I start my computer Activity Monitor after couple of minutes Turns out that it doesn't matter if some program is running on my computer or not, it happens every time I turn on my computer.

I recently purchased a TarDisk for my Mac, a microSD card for expanding the computer's memory.
The problem mentioned above started right after the "Pearing" process.
I understood that the mdworker task is a system software that takes care of Spotlight indexing. Since the "pearing" process of the TarDisk makes the OS to think the microSD card is part of the main Macintosh HD and since I have turned on FileVault again after the installation, I think Spotlight has difficulties indexing my SSD for some reason that has something to do with that.

In order to solve this, I tried to fix any possible flaws in my SSD.
So I have booted into Single-User Mode and run the file system consistency check command fsck -fy until it said the volume appears to be OK. I also run the First Aid tool on the Disk Utility app.
(Just to be clear, I have preformed those steps before installing the TarDisk, as the company instructed before beginning that installation process, but right now I am describing the steps I took in order to fix the problem mentioned above, after it appeared) In addition, I have also restarted the System Management Controller (SMC) on my Mac, following the instructions on apple's site.
Non of the above worked for me.
I saw a way to disable Spotlight's indexing for the entire SSD, but I don't want to do that, since it will make Spotlight unusable for searching things and that is the entire point of this tool.

I would like to get any suggestions for solving this issue.
What may cause it and what is a possible solution?

  • Welcome to Ask Different! You've got a lot of info here (good) and a lot of questions (not so good). Please try to keep your questions away from answers that would rely on opinion or that ask more than 1, focused question at a time. Take a look at How to Ask on how to ask a good question that has the best chance to be answered. - From Review - – fsb Jul 29 '16 at 23:48
  • @fbara, I edited my post accordingly. Is it okay now? – Matan Itzhak Jul 30 '16 at 5:36
  • Yes, it looks good now. Hopefully, those edits will help you get better answers to you question. – fsb Jul 30 '16 at 14:14
0

First of all, kernel_task gets higher (if I not wrong) because of the mdworker.

Talking now about the mdworker. Maybe the problem is not on your SSD at all. In this article recommends you to turn off Spotlight all devices. I recommend you to test instead with some folders of the SSD you might think Spotlight could get stuck in (large number of files, symlinks, ...). Also, you could try avoiding Spotlight accessing your external disks. Test until you get rid of the problem. Maybe you could find where the problem comes.

Also, you could try mdworker process always at 100%, even when not indexing this answer. Here founds that the problem resides in a Spotlight plugin. That could also be.

  • I've tried it already with no success. Making some parts of the drive inaccessible to Spotlight's indexing haven't solved the problem and I didn't want to go any further and disabling the entire SSD because I still wanted my content to be searchable through Spotlight. I also read the post you sent, and that is not my case - I was inspecting Spotlight plugins and nothing special showed up. – Matan Itzhak Aug 1 '16 at 19:57
  • Thats a serious problem then. I have no more ideas. – melchor629 Aug 1 '16 at 20:38
0

TL;DR - I haven't found a precise solution, TarDisk installation process didn't go well for the first time due to some glitch, formatting the computer has done the work.

I have contacted TarDisk's Support Team, as I suspected that the issue was due to the external drive I bought from them. They suggested me to perform file system consistency check (FSCK) and System Management Controller (SMC) reset. As mentioned in my question, I had already done those steps and it didn't help me in solving my problem.
Their further step was to uninstall the drive and then reinstalling it because there is a possibility that the installation process didn't go well.

When uninstalling TarDisk, one has to delete the Logical Volume Group that was created and made the computer's SSD drive and TarDisk's drive be seen as one unified drive.
I have decided not to perform a restoration from a TimeMechine backup, so I have deleted the entire drive and reinstalled the OS from scratch.

As it turns out, both from my own experience and from the support team response, the problem was caused by a glitch in the installation process.
That glitched process did expand the storage on my computer but it caused Spotlight trouble in indexing the drive in its unified form (containing both the computer's SSD drive and TarDisk's drive).
I also suspect that the indexing problem was caused because FileValt was turned on back again. In that case, maybe there were files on the external drive and their encryption was stored on the internal drive due to a problem during the installation process. That made indexing my files almost impossible and caused the mdworker process to consume all available RAM memory.

After a clear start, I've installed my programs again, then I've installed TarDisk, and only then I've activated FileVault. In that case, the encryption was made after TarDisk was installed and indexing was made possible again.
That has solved my problem and right now I can use my computer as usual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .