I'm installing Windows 7 on my Mac via Parallels. During installation I'm getting. "A required CD/DVD drive device driver is missing." message. Doesn't give me any option to proceed further. What am I doing wrong?

p.s. I hit same message using bootcamp.

I'm using Macbook Pro OS X, Core i7. Trying to install Windows 7 Pro 64bit.

enter image description here


This error commonly occurs when the Windows 7 DVD, or the ISO image used to create said DVD, is corrupted. I see this at work once every month or two so know it well.

Re-download the Windows 7 ISO image to use with Parallels. Also re-burn the new ISO image to DVD if you still need a physical disc (for Boot Camp).

If this error occurs with a retail DVD try and ask for a replacement or check that your optical drive is in full working order (having tried using a CD/DVD lens cleaner on it first).

  • Looks like I didn't burn the ISO correctly. When I "connected" parallel's to downloaded image file, it worked. Thank you for the tip. Sep 12 '11 at 15:53

Everyone seemed to think that re-burning the disk would fix the issue. It did for a lot of people. But I had a purchased copy that I didn't burn.

The fix for me was to let Windows boot up. You'll see the black screen with a progress bar where the windows installer starts up. Start tapping F8. You might have to hold Alt/Option while tapping. I tried both just to be sure the menu would pop up. Then select: Disable Driver Signature Enforcement.

Doing that let me continue through the installer.

  • i got this screen but macbook keyboad doesn't work in it
    – Metal Gear
    Jun 30 '15 at 17:12

You are using the USB flash drive option. Avoid booting from a USB flash drive; use a bootable DVD for installation and this will never happen again.


I went through all the post, tried most of them and a lot of them were not making any sense. Unfortunately I cannot come up with the exact way I solved the issue but here is what I did.

  1. Delete your actual VM, it is no good.
  2. Update your Parallels Desktop, I am working with 8.0.18608.
  3. Create the VM using a brand new downloaded ISO for which I used a download manager (ex. Folx)
  4. Recreate your VM, it workes just fine for me.

Honestly I don't think the iso file is the problem. If I were you I would try with the one you have right now. After I updated my Parallels it wasn't working until I realized I was still trying to install with the VM I created with the previous version. When I deleted and created a new one it worked.

So if you are reading this, just update your Parallels, delete your VMs and start over, don't worry about configuration it didn't do anything good for me, IDE or SATA. Just make sure you start fresh.

Hope it helps, cause for me, none of the other posts helped.



Actually I have found out that this also occurs if you are using usb3.0 ports. If you only have usb 3.0 ports you need to go into the bios and tell it to treat them as usb 2.0 ports in preboot


There is an absolute solution this problem;

  1. Burn iso image to DVD, period. Because this error appears just with USB stick.
  2. Want to use USB stick (like me) I know you won't believe me about my weird (odd) solution but it works :) Whenever I try to install Win7 from USB stick, this problem shows up. Then I examine USB stick's light. When error occured that light blink harmonic. I try to pull and push USB stick slowly and smoothly in its nest a couple times. When i see that light blink continuously then this error go away. Just pull and push very carefully.

Before that I tried USB stick to put another USB socket or other USB sticks but it didn't work because neither my USB sticks nor USB ports don't broken.

Finally the last word is Windows in Bootcamp doesn't like USB sticks much :D

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .