1

The title explains my configuration. I've done port forwarding on the FiOS router to my MacBook Pro but attempts to SSH from outside produce "network unreachable" (inside my home network SSH works fine).

Is the only way to get this to work by setting the Time Capsule configuration to DHCP & NAT then port forward from FiOS to the Time Capsule then port forward using the NAT configuration on the Time Capsule to the MacBook?

I really want to leave the Time Capsule in Bridge mode because traffic between my TiVo boxes and Macs/iPhone/iPad only work in that configuration.

  • Check your firewall settings. Also, how exactly are you accessing your network from the outside? – PoisonNinja Jul 26 '16 at 22:07
  • SSH is open in the firewall. I use the IP address of my personal domain which gets updated to the IP of the FiOS router. – Dave Elstner Jul 27 '16 at 13:42
  • The Time Capsule shouldn't affect anything. Try accessing your computer from inside your network, but using the external address. – PoisonNinja Jul 27 '16 at 16:44
  • What's FiOS?... – Max Ried Aug 28 '16 at 14:22
  • This is a huge, overly broad situation - but I'll try to get you a guided path outlining some of the steps and assumptions. – bmike Aug 28 '16 at 14:30
1

I would remove any setup you made on the routers to set up DMZ host, port forwarding, ssh after making a backup / notes of how you have things configured.

  1. enable NAT Port Mapping Protocol (NAT-PMP) or Universal Plug and Play (UPnP) on the FiOS router.
  2. Set up the AirPort in Bridge Mode
  3. Set up iCloud on the Mac to have Back To My Mac enabled (you can turn it off later - but this lets you use Apple's diagnostic test to verify NAT-PMP/UPnP are working on your specific network topology and settings.
  4. Power down the mac, then the AirPort, then the router. If any have battery backups, consider powering them down too. Start up the router, wait 60 seconds or so, then the airport, wait 60, then the Mac.

At this point iCloud preferences will show an error condition if you don't have inbound access to the Mac.

At this point you can go off Apple's Help in Finder - search for "Share your screen using Back to My Mac" - it should show you detailed steps and troubleshooting if it doesn't work. - https://help.apple.com/machelp/mac/10.12/index.html?localePath=en.lproj#/mh15597

To test remotely, use another Mac:

  1. sign in to the same iCloud account on that mac
  2. open terminal
  3. Shell menu - new remote connection
  4. select ssh
  5. select the host that is remote

Observe the shell command like ssh -p 22 remoteMac.442113223.members.btmm.icloud.com.

If you can ssh in, then you know the router and the mac are set up to pass incoming ssh traffic on the default port 22 to the Mac connected to your router.

At that point, you can then think about making up tunnels or know if you are set up for IPv4 or IPv6 on the FIOS connection and routers.

  • So - once you've done all this - you might decide to disable screen sharing entirely or for some users. Also review the ssh settings - you might choose to limit ssh to a subset of users if you wish. – bmike Aug 28 '16 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .