0

My background app (the one that gets activated when the current app quits) is some text editor. When I use the Cmd-Q shortcut to quit it and immediately afterwards let go of only the Cmd key, the text editor types a q character.

Of course I normally don't intentionally keep Q pressed. While using the Quartz keyboard layout I never even noticed this, but when I changed to the Dvorak layout, I occasionally saw this happen (probably because of the location of Q on the keyboard). It happens with both layouts though.

I'm pretty sure it's not a problem with specifically my Mac (EDIT: It only happens with my Logitech keyboard). It's quiet annoying, especially while coding since I quit the developing app a lot and the q in my source code makes it not compile anymore.

My questions are:

  1. Does this only happen on my Mac? Can someone test this? It only happens with the Logitech keyboard.

  2. How can I prevent this from happening? (other than always paying attention to let go of Q before Cmd)

  3. Why is this even happening? I don't think it's supposed to be like this.
2
  1. Tested and mine doesn't do this.
  2. Try to turn off key repeat: (mine below is not off)

enter image description here

  1. Maybe you have a non-Apple keyboard with anti-ghosting?
  • Ahh yes! It's the Logitech keyboard that's doing it! I didn't even think about that. I'll look up anti-ghosting now I guess – Silvan Mosberger Jul 26 '16 at 20:14
  • Cool np, let us know! :) – emotality Jul 26 '16 at 20:15
  • So the Apple keyboard works? – emotality Jul 26 '16 at 20:20
  • Yes, the Apple keyboard works. I couldn't find anything else regarding this problem though, no idea how to solve it. I'm probably gonna buy a new keyboard soon anyways though. – Silvan Mosberger Jul 26 '16 at 20:48
0

I have this same problem, and can confirm that it only seems to happen when I'm using my Logitech keyboard. I fiddled with lots of keyboard settings, but none of them stopped the errant "q" from happening. But I've found a (poor) solution that does work:

Solution: Whenever you press cmd+q, make sure you release the q key before releasing the cmd key. As long as you release the keys in this order, the "q" character won't be sent to the new foreground app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .