Yesterday, I tried to update to the second public beta of macOS Sierra. For some reason, however, the update process stopped shortly before the completion, and since there was no progress even after many hours, I decided to shut down.

Everything works fine as far as the startup is concerned, but I can not login with my regular user account. While the password is recognized as correct, the display turns black when my data are supposed to be loaded, and I am again asked to enter my password.

Neither restarts nor safe boots were of help. I also reinstalled macOS Sierra—probably the first public beta—via the recovery mode completely, but the problem is still there, even in safe mode. Apparently, all of the disk data are still there as well, but I can simply not login due to the black screen.

I tried to create a new admin user via Terminal to check if that account has the same issues. But the problem is that the sudo command, even whereis sudo and which sudo only gives me the line command not found after sudo, whereis and which, respectively.

echo $PATH gives me the response /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin. That seems rather long; is it alright?

I would appreciate your help, be it regarding the login issue or enabling the sudo command.

closed as unclear what you're asking by Allan, nohillside Jul 26 '16 at 18:11

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm voting to close this question as off-topic because it is about beta/pre-release software which is outside the scope as defined in the Help Center – Allan Jul 26 '16 at 17:35
  • Then feel free to only answer the question regarding the sudo command to create a new user via Terminal, which is not necessarily connected to the beta software. – H. Dopp Jul 26 '16 at 17:40
  • @Allan Questions about the public beta are on-topic, see meta.apple.stackexchange.com/questions/1712/… – nohillside Jul 26 '16 at 18:09
  • @H.Dopp Can you be a bit more specific about the state your system is in: Did you boot into single user mode, from the recovery partition or something else? Which OSX version is running there? – nohillside Jul 26 '16 at 18:11
  • Currently, I am running the first public beta which I reinstalled via recovery mode in the regular mode. Still, I have the login issues from the second public beta: I can not login with my regular user account. That is why I would like to use Terminal to create a second user to check if that account has the same issues; that, however, is impossible since the sudo command, which is necessary for creating a new user, “is not found”. I suspect that the upgrade to the second public beta caused severe issues, but I am not sure what exactly is wrong in the system. – H. Dopp Jul 26 '16 at 18:19